(甲)1015 Reversible Primes (20 分)

题目:

A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.(当输入的N为负数时,结束输入)。

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

 题意:

给你两个数字N和D,题目要求,当N是素数且N以D为基数时也是素数,就输出Yes,否则输出No;

思路:

(1).先判断N是否是素数,不是素数,直接输出No;是素数进行第(2)步;

(2).把十进制的N,转换成以D为基数的数字;

(3).把转换后的数字再反转后再转换成十进制的数字;

(4).判断反转后的数字是否是素数;

提示:在转换进制和再转换成十进制数字时可以使用队列(queue)来作为中间的过度,这样这道题会更简单。

代码如下:

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;

int p[101000];
int n,d;

void init()//素数打表;
{
    memset(p,0,sizeof p);
    p[1]=1;
    for(int i=2; i<=101000; i++)//等于1代表不是素数,等于0代表是素数;
    {
        if(p[i]==0)
        {
            for(int j=2; j*i<=101000; j++)
                p[i*j]=1;
        }
    }
    return ;
}

queue<int>q;
int flag=0;

int main()
{
    init();
    while(~scanf("%d",&n))
    {
        if(n<0)//注意结束的条件;
            break;
        scanf("%d",&d);
        if(p[n]==1)//不是素数;
            printf("No\n");
        else
        {
            while(!q.empty())//清空队列;
                q.pop();
            int k=n;
            while(k)//转换进制;
            {
                q.push(k%d);
                k=k/d;
            }
            k=0;
            while(!q.empty())//反转后转换成十进制;
            {
                k=k*d+q.front();
                q.pop();
            }
            //printf("k=====%d\n",k);
            if(p[k]==0)//判断转换后的数是否是素数;
                printf("Yes\n");
            else
                printf("No\n");
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值