1015 Reversible Primes (20 分)

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

Solution Code:

/***********************
首先,判断n是否是素数,如果是素数,则继续执行,否则,输出No
然后,判断n在d进制下逆数是否是的素数(逆数指数字顺序颠倒)
****************************/
#include <iostream>
#include <cmath>
using namespace std;

// 求得D进制下的逆数,并转化为十进制
int getRevNumber(int number, int raddix)
{
	int rev_result[1000];
	int result = 0;
	int index = 0;
	// 求得D进制下的逆数
	while(number != 0) {
		rev_result[index++] = number % raddix;
		number /= raddix;
	}
	// 转化为10进制数
	for (int i = 0; i < index; ++i){
		result = result*raddix + rev_result[i];
	}
	return result;
}

// 判断是否为素数
bool isPrime(int number)
{
	if (number <= 1)
		return false;
	if (number == 2 || number == 3)
		return true;
	else {
		int end = int(sqrt(number)) + 1;
		for (int i = 2; i < end; ++i) {
			if (number % i == 0)
				return false;
		}
		return true;
	}
}

int main()
{
	int n, d;
	while (cin >> n && n > 0) {
		cin >> d;
		if (!isPrime(n)) {
			cout << "No" << endl;
			continue;
		}
		if (isPrime(getRevNumber(n, d))) {
			cout << "Yes" << endl;
		}
		else
			cout << "No" << endl;
	}

	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值