HDU 4055 Number String(DP)

Number String

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1855    Accepted Submission(s): 874


Problem Description
The signature of a permutation is a string that is computed as follows: for each pair of consecutive elements of the permutation, write down the letter 'I' (increasing) if the second element is greater than the first one, otherwise write down the letter 'D' (decreasing). For example, the signature of the permutation {3,1,2,7,4,6,5} is "DIIDID".

Your task is as follows: You are given a string describing the signature of many possible permutations, find out how many permutations satisfy this signature.

Note: For any positive integer n, a permutation of n elements is a sequence of length n that contains each of the integers 1 through n exactly once.
 

Input
Each test case consists of a string of 1 to 1000 characters long, containing only the letters 'I', 'D' or '?', representing a permutation signature.

Each test case occupies exactly one single line, without leading or trailing spaces.

Proceed to the end of file. The '?' in these strings can be either 'I' or 'D'.
 

Output
For each test case, print the number of permutations satisfying the signature on a single line. In case the result is too large, print the remainder modulo 1000000007.
 

Sample Input
  
  
II ID DI DD ?D ??
 

Sample Output
  
  
1 2 2 1 3 6
Hint
Permutation {1,2,3} has signature "II". Permutations {1,3,2} and {2,3,1} have signature "ID". Permutations {3,1,2} and {2,1,3} have signature "DI". Permutation {3,2,1} has signature "DD". "?D" can be either "ID" or "DD". "??" gives all possible permutations of length 3.
 

Author
HONG, Qize
 

Source
 

Recommend
lcy


题意:

把1-n的数字排列,满足给定字符串,字符串中I代表上升,D代表下降,?两者皆可。求满足字符串的数列一共多少个。

思路:

建立二位数组。dp[m][n]表示长度为m以n为结尾。发现如果增加一个元素x,那么把之前元素大于等于m的数字都 +1 之后前面的序列依旧满足关系。再使用前缀和优化,就可以把复杂度降低至n*。

/*************************************************************************
    > File Name: new.cpp
    > Author: tahara
    > Mail: ping19963@gmail.com 
    > Created Time: Wed 05 Oct 2016 08:55:02 PM CST
 ************************************************************************/

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <map>
#define MOD 1000000007 
using namespace std;

int dp[1010][1010];

int main()
{
	int len, i, j, at;
	char str[1100];
	dp[1][1] = 1;
	while(~scanf("%s", str)){
		len = strlen(str);
		for(i = 0; i < len; i++){
			at = i + 2;
			for(j = 1; j < at; j++){
				dp[at - 1][j] = (dp[at - 1][j] + dp[at - 1][j - 1]) % MOD;
			}
			dp[at - 1][j] = 0;
			if(str[i] == 'I'){
				for(j = 1; j <= at; j++){
					dp[at][j] = dp[at - 1][j - 1];
				}
			}
			else if(str[i] == 'D'){
				for(j = 1; j <= at; j++){
					dp[at][j] = (dp[at - 1][at - 1] - dp[at - 1][j - 1] + MOD) % MOD;
				}
			}
			else{
				for(j = 1; j <= at; j++){
					dp[at][j] = dp[at - 1][at - 1];
				}
			}
		}
	at = i + 2;
	for(j = 1; j < at; j++)
		dp[at - 1][j] = (dp[at - 1][j] + dp[at - 1][j - 1]) % MOD;
	printf("%d\n", dp[at - 1][j - 1]);
	}

	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值