HDU 4055 Number String (dp的思想)

 

 


Number String

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1052    Accepted Submission(s): 456


Problem Description

The signature of a permutation is a string that is computed as follows: for each pair of consecutive elements of the permutation, write down the letter 'I' (increasing) if the second element is greater than the first one, otherwise write down the letter 'D' (decreasing). For example, the signature of the permutation {3,1,2,7,4,6,5} is "DIIDID".

Your task is as follows: You are given a string describing the signature of many possible permutations, find out how many permutations satisfy this signature.

Note: For any positive integer n, a permutation of n elements is a sequence of length n that contains each of the integers 1 through n exactly once.

 


 

Input

Each test case consists of a string of 1 to 1000 characters long, containing only the letters 'I', 'D' or '?', representing a permutation signature.

Each test case occupies exactly one single line, without leading or trailing spaces.

Proceed to the end of file. The '?' in these strings can be either 'I' or 'D'.

 


 

Output

For each test case, print the number of permutations satisfying the signature on a single line. In case the result is too large, print the remainder modulo 1000000007.

 


 

Sample Input

II
ID
DI
DD
?D
??

 


 

Sample Output

1
2
2
1
3
6
Hint
Permutation {1,2,3} has signature "II". Permutations {1,3,2} and {2,3,1} have signature "ID". Permutations {3,1,2} and {2,1,3} have signature "DI". Permutation {3,2,1} has signature "DD". "?D" can be either "ID" or "DD". "??" gives all possible permutations of length 3.

 


 

Author

HONG, Qize

 


 

Source

2011 Asia Dalian Regional Contest

 


 

Recommend

lcy

 

 

 

#include <iostream>
#include <cstring>
#include <cstdio>
#include <string>
using namespace std;

const int maxn=1010;
const int mod=1000000007;
string st;
long long dp[maxn][maxn],sum[maxn];

void computing(){
	int len=st.length();
	dp[1][1]=1;
	sum[1]=1;sum[0]=0;
	for(int i=2;i<=1+len;i++){
		for(int j=1;j<=i;j++){
			if(st[i-2]=='D') dp[i][j]=sum[j-1];
			else if(st[i-2]=='I') dp[i][j]=((sum[i-1]-sum[j-1])%mod+mod)%mod;
			else dp[i][j]=sum[i-1];
		}
		sum[0]=0;
		for(int j=1;j<=i;j++){
			sum[j]=(sum[j-1]+dp[i][j])%mod;
		}
	}
	cout<<sum[len+1]<<endl;
}

int main(){
	while(cin>>st){
		computing();
	}
	return 0;
}


 

 

转载于:https://www.cnblogs.com/toyking/p/3797385.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值