POJ 3616 Milking Time

原文链接

原题:
Description
Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.
Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.
Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input
* Line 1: Three space-separated integers: N, M, and R

Output
* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input
12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output
43

思路:
动态规划。
dp[i] = max(dp[i],dp[j] + milk[i].eff)

AC代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstdlib>
#include <cstring>
#include <cmath>
using namespace std;

int N,M,R;
long long int dp[1005];  //当第i个间隔处最后一次挤奶时,最大为dp[i]
struct interval{
    int start,end,eff;
}milk[1005];
long long int ans;

long long int max(long long int a,long long int b){
    return a > b ? a : b;
}

bool cmp(interval m,interval n)
{
    if(m.start != n.start){
        return m.start < n.start;
    }
    else return m.end < n.end;
}

int main()
{
    int i,j;
    scanf("%d %d %d",&N,&M,&R);
    for(i = 1; i <= M; i++){
        scanf("%d %d %d",&milk[i].start,&milk[i].end,&milk[i].eff);
        milk[i].end += R;
    }
    sort(milk + 1, milk + M + 1, cmp);
    for(i = 1; i <= M; i++){
        dp[i] = milk[i].eff;
        for(j = 1; j < i; j++){
            if(milk[j].end <= milk[i].start){
                dp[i] = max(dp[i],dp[j] + milk[i].eff);
            }
        }
    }
    for(i = 1; i <= M; i++){  //注意:最后一次挤奶未必是在最后一个间隔!!! 
        ans = max(ans,dp[i]);
    }
    printf("%lld\n",ans);
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值