hdu 4848 Wow! Such Conquering! (暴搜+强剪枝)

Wow! Such Conquering!

Time Limit: 15000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
  
  
There are n Doge Planets in the Doge Space. The conqueror of Doge Space is Super Doge, who is going to inspect his Doge Army on all Doge Planets. The inspection starts from Doge Planet 1 where DOS (Doge Olympic Statue) was built. It takes Super Doge exactly T xy time to travel from Doge Planet x to Doge Planet y. With the ambition of conquering other spaces, he would like to visit all Doge Planets as soon as possible. More specifically, he would like to visit the Doge Planet x at the time no later than Deadline x. He also wants the sum of all arrival time of each Doge Planet to be as small as possible. You can assume it takes so little time to inspect his Doge Army that we can ignore it.
 

Input
  
  
There are multiple test cases. Please process till EOF. Each test case contains several lines. The first line of each test case contains one integer: n, as mentioned above, the number of Doge Planets. Then follow n lines, each contains n integers, where the y-th integer in the x-th line is T xy . Then follows a single line containing n - 1 integers: Deadline 2 to Deadline n. All numbers are guaranteed to be non-negative integers smaller than or equal to one million. n is guaranteed to be no less than 3 and no more than 30.
 

Output
  
  
If some Deadlines can not be fulfilled, please output “-1” (which means the Super Doge will say “WOW! So Slow! Such delay! Much Anger! . . . ” , but you do not need to output it), else output the minimum sum of all arrival time to each Doge Planet.
 

Sample Input
  
  
4 0 3 8 6 4 0 7 4 7 5 0 2 6 9 3 0 30 8 30 4 0 2 3 3 2 0 3 3 2 3 0 3 2 3 3 0 2 3 3
 

Sample Output
  
  
36 -1 Explanation: In case #1: The Super Doge travels to Doge Planet 2 at the time of 8 and to Doge Planet 3 at the time of 12, then to Doge Planet 4 at the time of 16. The minimum sum of all arrival time is 36.
 

题意:
有n个点(n<=30),从第一个点出发,要遍历完所有点,遍历每个点要在time[i]之前遍历,求到达每个点的距离之和。

感谢大牛 Sd.无心插柳and  在错觉中生活 提供的思路。

思路:
30个点,果断暴搜就行。根据time[i]剪枝,一个强剪枝就是走过一条边,还剩下num个点的话,答案是要加edge*num的,当前答案大于答案的时候剪枝就行了。

代码1:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#define maxn 1005
#define MAXN 100005
#define mod 100000000
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

int n,m,ans,tot;
int dist[35][35],time[35],bit[35];

void floyd()
{
    int i,j,k;
    for(k=0;k<n;k++)
    {
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                dist[i][j]=min(dist[i][j],dist[i][k]+dist[k][j]);
            }
        }
    }
}
void dfs(int u,int s,int cost,int sum,int num)
{
    if(sum>=ans) return ;
    if(s==tot)
    {
        ans=min(ans,sum);
        return ;
    }
    int i;
    for(i=1;i<n;i++)
    {
        if(s&bit[i]) continue ;
        if(cost+dist[u][i]>time[i]) return ;
    }
    for(i=1;i<n;i++)
    {
        if(s&bit[i]) continue ;
        dfs(i,s|bit[i],cost+dist[u][i],sum+dist[u][i]*num,num-1);
    }
}
int main()
{
   int i,j,t;
   for(i=0;i<=30;i++)
   {
       bit[i]=(1<<i);
   }
   while(~scanf("%d",&n))
   {
       for(i=0;i<n;i++)
       {
           for(j=0;j<n;j++)
           {
               scanf("%d",&dist[i][j]);
           }
       }
       for(i=1;i<n;i++)
       {
           scanf("%d",&time[i]);
       }
       tot=bit[n]-1;
       floyd();
       ans=INF;
       dfs(0,1,0,0,n-1);
       if(ans==INF) ans=-1;
       printf("%d\n",ans);
   }
}


顺便简单学习了一下双向链表的知识。
代码2:(搜索时用双向链表)
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#define maxn 1005
#define MAXN 100005
#define mod 100000000
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

int n,m,ans,tot,len;
int dist[35][35],time[35],R[35],L[35];

void floyd()
{
    int i,j,k;
    for(k=1;k<=n;k++)
    {
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                dist[i][j]=min(dist[i][j],dist[i][k]+dist[k][j]);
            }
        }
    }
}
void dfs(int u,int cost,int sum,int num)
{
    for(int i=R[0];i;i=R[i])
    {
        if(cost+dist[u][i]>time[i]) return ;
    }
    if(sum>=ans) return ;
    R[L[u]]=R[u]; L[R[u]]=L[u];  // 删除u
    if(R[0]==0)
    {
        ans=min(ans,sum);
        R[L[u]]=L[R[u]]=u;
        return ;
    }
    for(int i=R[0];i;i=R[i])
    {
        dfs(i,cost+dist[u][i],sum+dist[u][i]*num,num-1);
    }
    R[L[u]]=L[R[u]]=u;  // 恢复u
}
int main()
{
   int i,j,t;
   while(~scanf("%d",&n))
   {
       for(i=1;i<=n;i++)
       {
           for(j=1;j<=n;j++)
           {
               scanf("%d",&dist[i][j]);
           }
       }
       for(i=2;i<=n;i++)
       {
           scanf("%d",&time[i]);
       }
       floyd();
       for(i=0;i<=n;i++)  // 初始化
       {
           R[i]=i+1; L[i]=i-1;
       }
       R[n]=0; L[0]=n;
       ans=INF;
       dfs(1,0,0,n-1);
       if(ans==INF) ans=-1;
       printf("%d\n",ans);
   }
}




  
  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值