UVa10252:Common Permutation

题目:统计两行小写字母构成的字符串中相同的字母,并按字典序输出。
注: 先排序然后比较输出。(防止测资存在空格或是大写字母)

Description

 

Given two strings of lowercase letters, a and b, print the longest string x of lowercase letters such that there is a permutation of x that is a subsequence of a and there is a permutation of x that is a subsequence of b.

Input

Input file contains several lines of input. Consecutive two lines make a set of input. That means in the input file line 1 and 2 is a set of input, line 3 and 4 is a set of input and so on. The first line of a pair contains a and the second contains b. Each string is on a separate line and consists of at most 1000 lowercase letters.

Output

For each set of input, output a line containing x. If several x satisfy the criteria above, choose the first one in alphabetical order.


Sample Input

Sample Output

pretty

women

walking

down

the

street

e

nw

et


#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <iostream>

using namespace std;

char arr1[1001]={0}, arr2[1001]={0};

int main()
{
	while(gets(arr1) && gets(arr2))
	{
		int len1=strlen(arr1);
		int len2=strlen(arr2);
		
		sort(arr1, arr1+len1);
		sort(arr2, arr2+len2);
		
		int i, j;
		for(i=0, j=0; i<len1 && j<len2; )
		{
			if(arr1[i]==' ' || arr1[i]>='A' && arr1[i]<='Z') i++;
			if(arr2[j]==' ' || arr2[j]>='A' && arr2[j]<='Z') j++; //移除空格或者是大写字母
			if(arr1[i]==arr2[j])
			{
				printf("%c",arr1[i]);
				i++;
				j++;
			}
			if(arr1[i]<arr2[j]) i++;
			if(arr1[i]>arr2[j]) j++;
		}
		printf("\n");
		
		memset(arr1, 0, sizeof(arr1));
		memset(arr2, 0, sizeof(arr2));
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值