PAT_A 1013. Battle Over Cities (25)

1013. Battle Over Cities (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0
这道题考察最小生成树和集合
用一个二维数组来存储图。
简单考虑的话,需要修的路等于所有的城市数-已有的路径数-2
注意数已有路径数时要避免使最小生成树出现环,即若两个城市已在一个集合里,即使这两个城市中间有路也不需要把这条路数进去。
最后注意set数组在每个case下都要更新一次。
 
 
#include <stdio.h>
#define MAX 1000
int Graph[MAX][MAX];
int set[MAX];
int Find(int n);
void Union(int a, int b);
int main()
{
	int n, m, k;
	scanf("%d %d %d", &n, &m, &k);
	for (int i = 1; i <= n; i++) {
		for (int j = 1; j <= n; j++)
			Graph[i][j] = 0;
	}
	for (int i = 0; i < m; i++) {
		int d1, d2;
		scanf("%d %d", &d1, &d2);
		Graph[d1][d2] = Graph[d2][d1] = 1;
	}
	for (int i = 0; i < k; i++) {
		int c;
		int pathnum = 0;
		scanf("%d", &c);
		for (int j = 1; j <= n; j++)
			set[j] = -1;
		for (int j = 1; j <= n; j++) {
			if (j == c)
				continue;
			for (int k = 1; k <= n; k++) {
				if (k == c)
					continue;
				else {
					if (Graph[k][j] != 0) {
						if (Find(j) != Find(k)) {
							Union(k, j);
							pathnum++;
						}
					}
				}
			}
			
		}
		printf("%d\n", n - pathnum - 2);
	}
	return 0;
}
int Find(int n)
{
	while (set[n] > 0)
		n = set[n];
	return n;
}
void Union(int a, int b)
{
	int roota, rootb;
	roota = Find(a);
	rootb = Find(b);
	if (roota < rootb) {
		set[roota] += set[rootb];
		set[rootb] = roota;
	}
	else {
		set[rootb] += set[roota];
		set[roota] = rootb;
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值