HDU 1253 胜利大逃亡(空间BFS)

Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.


 

Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.
 

Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.
 

Sample Input
  
  
1 3 3 4 20 0 1 1 1 0 0 1 1 0 1 1 1 1 1 1 1 1 0 0 1 0 1 1 1 0 0 0 0 0 1 1 0 0 1 1 0
 

Sample Output
  
  
11
 
题目给出的图是为了更直观就把一个空间拆成了3个平面。在原来平面的基础上加上z轴,方法和平面的一样。
注意输入用scanf
其实应该还可以剪枝,如果某点到终点所需时间已经大于T了就可以不必入队,不过没剪枝的也能过,于是就不管啦~~~


//Must so
#include<iostream>
#include<algorithm>
#include<string>
#include<sstream>
#include<queue>
#include<vector>
#include<set>
#include<map>
#include<cstring>
#include<cstdio>
#include<cmath>
#define mem(a,x) memset(a,x,sizeof(a))
#define sqrt(n) sqrt((double)n)
#define pow(a,b) pow((double)a,(int)b)
#define inf 1<<29
#define NN 1000006
using namespace std;
const double PI = acos(-1.0);
typedef long long LL;

int mp[55][55][55];
int dx[6] = {0,0,-1,1,0,0};
int dy[6] = {0,0,0,0,-1,1};
int dz[6] = {1,-1,0,0,0,0};
int X,Y,Z,T;
struct Node
{
    int x,y,z,step;
};
inline bool ok(Node a)
{
    return a.x >= 0&&a.y >= 0&&a.z >= 0&&a.x < X&&a.y < Y&&a.z < Z ;
}
int bfs()
{
    queue<Node>q;
    Node s;
    s.x = 0,s.y = 0,s.z = 0,s.step = 0;
    q.push(s);
    vis[0][0][0] = 1;
    while (!q.empty())
    {
        Node h;
        h = q.front();
        if (h.step > T) return -1;
        if (h.x == X-1&&h.y == Y-1&&h.z == Z-1) return h.step;
        q.pop();
        for (int i = 0;i < 6;i++)
        {
            Node nx;
            nx.x = h.x + dx[i];
            nx.y = h.y + dy[i];
            nx.z = h.z + dz[i];
            nx.step = h.step + 1;
            if (ok(nx))
            {
                if (mp[nx.x][nx.y][nx.z] == 0)
                {
                    mp[nx.x][nx.y][nx.z] = 1;
                    vis[nx.x][nx.y][nx.z] = 1;
                    q.push(nx);
                }
            }
        }
    }
    return -1;
}
int main()
{
    int K;
    scanf("%d",&K);
    while (K--)
    {
        //cin>>X>>Z>>Y>>T;
        scanf("%d%d%d%d",&X,&Y,&Z,&T);
        for (int x = 0;x < X;x++)
        {
            for (int y = 0;y < Y;y++)
            {
                for (int z = 0;z < Z;z++)
                {
                    scanf("%d",&mp[x][y][z]);
                }
            }
        }
        cout<<bfs()<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值