HDU 1394 Minimum Inversion Number(用规律取代线段树)

Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

Author
CHEN, Gaoli
 

Source
 


   
   
题意:
开始不知道什么是逆序数列,百度之后才知道。。。
意思就是说数列1    3      2      5      4     0里面
(1,0)(3,2)(3,0)(2,0)(5,4)(4,0)有6对
满足的i<j而ai>aj的数对
题目给出一个数列,可以将第一个数放到数列尾部
这样循环n次可以得到n组数列
求这n组里面的最小逆序数
分析:
样例模拟一遍,发现规律:
	如果是0到n的排列,那么如果把第一个数放到最后,
    	对于这个数列,逆序数是减少a[i],而增加n-1-a[i]
	所以直接找到输入数列的逆序数,然后一个循环即可找出所有数列的逆序数
	至于第一组的找法,表示n只有5*10^3,故一个二重循环搞定。。。
	另外,这题被分类为线段树。。。。暴力过了。。。。。


#include<cstdio>
#include<algorithm>
using namespace std;
const int N = 5000;
int a[N + 5];
int main()
{
    int n;
    while (~scanf("%d",&n))
    {
        for (int i = 1;i <= n;++i) scanf("%d",&a[i]);
        int sun = 0;
        for (int i = 1;i <= n;++i)
            for (int j = i+1;j <= n;++j)
                if (a[j] < a[i]) sun++;
        int ans = sun;
        for (int i = 1;i <= n;++i)
        {
            sun = sun - a[i] + (n-1-a[i]);
            ans = min(ans,sun);
        }
        printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值