1025

Constructing Roads In JGShining's Kingdom

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20433    Accepted Submission(s): 5755


Problem Description
JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource. 

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II. 

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones. 

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.



In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
 

Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
 

Output
For each test case, output the result in the form of sample. 
You should tell JGShining what's the maximal number of road(s) can be built. 
 

Sample Input
  
  
2 1 2 2 1 3 1 2 2 3 3 1
 

Sample Output
  
  
Case 1: My king, at most 1 road can be built. Case 2: My king, at most 2 roads can be built.



最长上升子序列

因为按顺序走富城,连接的穷城编号必须是递增的

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

#define MAXN 50010 

using namespace std;

int n;
int kkke[MAXN];
int ans[MAXN],top;

int main()
{
	freopen("input.txt","r",stdin);
	freopen("output.txt","w",stdout);
	int cnt=1;
	while(scanf("%d",&n)==1)
	{
		int a,b;
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d",&a,&b);
			kkke[a]=b;
		}
		top=1;
		ans[0]=kkke[1];
		for(int i=2;i<=n;i++)
		{
			if(kkke[i]>ans[top-1])ans[top++]=kkke[i];
			else
			{
				int left=0,right=top-1,mid;
				while(left<right)
				{
					mid=(left+right)>>1;
					if(ans[mid]<kkke[i])left=mid+1;
					else right=mid;
				}
				ans[left]=kkke[i];
			}
		}
		if(top==1)printf("Case %d:\nMy king, at most 1 road can be built.\n\n",cnt);
		else printf("Case %d:\nMy king, at most %d roads can be built.\n\n",cnt,top);
		cnt++;
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
MySQL错误1025通常表示出现了死锁问题,也就是多个事务同时请求相同资源导致互相等待。这种情况下,一个事务被阻塞,直到其他事务释放资源。常见的错误信息是 "LOCK wait timeout exceeded"。 解决这个问题的方法可以通过以下步骤来进行: 1. 首先,可以使用以下命令检查当前正在使用的表:`show OPEN TABLES where In_use > 0;`,以及查看当前的进程列表:`show processlist;`。这些命令可以帮助你确定是否有其他的进程正在使用相同的表或资源。 2. 如果第一步没有找到问题所在,可以使用以下命令查询InnoDB锁和等待信息:`SELECT * FROM INFORMATION_SCHEMA.INNODB_LOCKS;`和`SELECT * FROM INFORMATION_SCHEMA.INNODB_LOCK_WAITS;`。这些命令可以帮助你查看当前的锁定情况和等待情况。 3. 如果以上步骤还没有找到问题所在,可以参考这篇文章中的方法,使用`select * from information_schema.innodb_trx`命令找到未提交的事务,并通过`kill`命令终止该事务。 通过以上的方法,你应该能够解决MySQL错误1025的问题。如果问题仍然存在,你可能需要进一步检查你的数据库配置和应用程序代码,以确保没有其他潜在的问题。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [MySQL ERROR 1025 - Error on rename of ‘...‘ 和1005 - Can‘t create table ...中可能存在的问题](https://blog.csdn.net/impact_factor/article/details/119843261)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] - *2* *3* [mysql 1025 LOCK 死锁 解决](https://blog.csdn.net/opopopwqwqwq/article/details/79585010)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值