HDU 5950 Recursive sequence

Recursive sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 58    Accepted Submission(s): 39


Problem Description
Farmer John likes to play mathematics games with his N cows. Recently, they are attracted by recursive sequences. In each turn, the cows would stand in a line, while John writes two positive numbers a and b on a blackboard. And then, the cows would say their identity number one by one. The first cow says the first number a and the second says the second number b. After that, the i-th cow says the sum of twice the (i-2)-th number, the (i-1)-th number, and  i4 . Now, you need to write a program to calculate the number of the N-th cow in order to check if John’s cows can make it right. 
 

Input
The first line of input contains an integer t, the number of test cases. t test cases follow.
Each case contains only one line with three numbers N, a and b where N,a,b <  231  as described above.
 

Output
For each test case, output the number of the N-th cow. This number might be very large, so you need to output it modulo 2147493647.
 

Sample Input
  
  
2 3 1 2 4 1 10
 

Sample Output
  
  
85 369
Hint
In the first case, the third number is 85 = 2*1十2十3^4. In the second case, the third number is 93 = 2*1十1*10十3^4 and the fourth number is 369 = 2 * 10 十 93 十 4^4.

主要就是构造矩阵  


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <vector>
#include <stack>
#include <map>
#include <cmath>

using namespace std;

typedef long long ll;
typedef unsigned long long ull;
typedef unsigned int uint;


const int INF = 0x7fffffff;
const ll m = (ll)2147493647;

struct Matrix {
    ll det[10][10];
};

Matrix yy,xx;


Matrix matrix;

Matrix Mul(Matrix x, Matrix y);
Matrix Pow(int n);

int main()
{
#ifdef Floyd
    freopen("in.txt", "r", stdin);
#endif // Floyd
	ll yyy[7][7] = { {1,2,1,0,0,0,0},
					  {1,0,0,0,0,0,0},
					  {0,0,1,4,6,4,1},
					  {0,0,0,1,3,3,1},
					  {0,0,0,0,1,2,1},
					  {0,0,0,0,0,1,1},
					  {0,0,0,0,0,0,1},
					  };
	for(int i = 0;i<7;i++)
	{
		for(int j = 0;j<7;j++)
		{
			matrix.det[i][j] = yyy[i][j];
		}
	}
//	for(int i = 0;i<7;i++)
//	{
//		for(int j = 0;j<8;j++)
//		{
//			printf("%d ",yy.det[i][j]);
//		}
//		puts("");
//	}
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int n;
		ll a,b;
		scanf("%d%I64d%I64d",&n,&a,&b);
		a %= m;
		b %= m;
		if(n == 1)
        {
            printf("%I64d\n",a);
            continue;
        }
        if(n == 2)
        {
            printf("%I64d\n",b);
            continue;
        }

		yy = Pow(n-2);
		xx.det[0][0] = b;
		xx.det[1][0] = a;
		xx.det[2][0] = 81;
		xx.det[3][0] = 27;
		xx.det[4][0] = 9;
		xx.det[5][0] = 3;
		xx.det[6][0] = 1;
        Matrix ans = Mul(yy,xx);
        ll ANS = ans.det[0][0]%m;
        printf("%I64d\n",ANS);
	}


    return 0;
}

Matrix Mul(Matrix x, Matrix y)      //????
{
    Matrix ret;
    for (int i = 0; i < 10; ++i) {
        for (int j = 0; j < 10; ++j) {
            ret.det[i][j] = 0;
            for (int k = 0; k < 10; ++k) {
                ret.det[i][j] += (x.det[i][k] %m)* (y.det[k][j]%m);
                ret.det[i][j] %= m;
            }

        }
    }
    return ret;
}

Matrix Pow(int n)       //???
{
    if (n == 1) {
        return matrix;
    }
    if (n & 1) {
        return Mul(matrix, Pow(n - 1));
    }
    Matrix t = Pow(n >> 1);
    return Mul(t, t);
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值