1019 of dp

Problem S

Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 68   Accepted Submission(s) : 22
Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.<br>The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0&lt;N&lt;1000) kinds of facilities (different value, different kinds).<br>
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.<br>A test case starting with a negative integer terminates input and this test case is not to be processed.<br>
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.<br>
 

Sample Input
  
  
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output
  
  
20 10 40 40
 题目要求:要求给两个机构分钱,要做到尽可能的平分,若不能平分则让第一个分到的钱数大于第二个的。
 解题思路:这是一个多重背包的题,背包体积为价值乘数量最后除以二,而价值和物品体积相同,然后可以运用二进制的枚举对每件物品进行优化,  套用多重模板即可,输出的即为第二个机构的钱数即可。
 ps:我要再一次的吐槽杭电的服务器,竟然在while里面判断就错,拿出来就对。
解题代码:
#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;
int v,c,n,d[260000],a[100][3];
int dp()
{
    memset(d,0,sizeof(d));
    int i,j,k;
    for(i=1;i<=n;i++){
        for(k=1;k<=a[i][2];k=k*2){
        for(j=v;j>=k*a[i][1];j--)
            d[j]=max(d[j],d[j-k*a[i][1]]+k*a[i][1]);
        }
            k=k/2;
        if(k!=a[i][2])
        {
            int ans=(a[i][2]-k)*a[i][1];
            for(j=v;j>=ans;j--)
            d[j]=max(d[j],d[j-ans]+ans);
        }
    }return d[v];
}
int main()
{
    int i,j,v1;
    while(cin>>n)
    {
        if(n<0)break;
        v=0;
         for(i=1;i<=n;i++){
           cin>>a[i][1];//钱
           cin>>a[i][2];//数量
           v+=a[i][1]*a[i][2];
         }v1=v;
         v=v/2;c=v1-dp();//v1为奇数时会出现误差
         cout<<c<<" "<<v1-c<<endl;
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值