1024 of dp

Problem X

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 24   Accepted Submission(s) : 16
Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.<br>The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.<br>If he had M units of money, what’s the maximum value iSea could get?<br><br>
 

Input
There are several test cases in the input.<br><br>Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.<br>Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.<br><br>The input terminates by end of file marker.<br><br>
 

Output
For each test case, output one integer, indicating maximum value iSea could get.<br><br>
 

Sample Input
  
  
2 10 10 15 10 5 5 3 10 5 10 5 3 5 6 2 7 3
 

Sample Output
  
  
5 11
题目要求:有一定的钱数和一些物品,要求买到的物品价值最大,这些物品有一个限制条件,在低于某个金额数目则不能买。
解题思路:本来以为是二维的背包问题,后来发现没法写,后来看了看别人的博客发现一件物品可能在前边买了其他物品后就不能买了。所以说需要在
运用背包前进行一个预处理可以看做物品函数的性价比,若前两项差值越小则性价比越高。然后进行01背包即可.
解题代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string.h>
using namespace std;
int max(int a,int b)
{return a>b?a:b;}
struct th
{ int p,q,v;};
th s[5100];
int d[5100],w,n,t,v,c;
bool comp(th a,th b)
{return a.q-a.p<b.q-b.p;}
int dp()
{
    int i,j;
    for(i=1;i<=v;i++)
        d[i]=0;
    for(i=1;i<=t;i++)
     for(j=v;j>=s[i].p;j--)
        if(j>=s[i].q)
    {
        d[j]=max(d[j-s[i].p]+s[i].v,d[j]);
    }
    return d[v];
}
int main()
{
    while(cin>>t)
    {

       cin>>v;
       for(int i=1;i<=t;i++)
       {  cin>>s[i].p;
          cin>>s[i].q;
          cin>>s[i].v;
       }
       sort(s+1,s+t+1,comp);
       cout<<dp()<<endl;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值