POJ 3624 Charm Bracelet

Description

Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability’ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

分析

典型的01背包问题,求n个物品放入背包的最大价值,一个物品的重量为w[i],价值为v[i],放入与不放入二选一。
递推式:m[i][j] = max(m[i-1][j], max[i - w[i]][j] + v[i])。
在此处不能用二维数组,会超内存限制。

实现

程序实现如下,要说的是优化运行时间的过程,用scanf/printf代替cin/cout节省 50ms , 状态转移方程由:

int temp = dp[j - w[i]] + d[i];
dp[j] = max(dp[j], temp);

换为:

int temp = dp[j - w[i]] + d[i];
if (dp[j] < temp) {
  dp[j] = temp;
}

节省了 110ms 左右,函数调用真费时间。。

#include <iostream>
#define N 3402
#define M 12881
int dp[M]={0};
int w[N];
int d[N];

int main()
{
//  freopen("in.txt", "r", stdin);
    int n, m;
    scanf("%d%d", &n, &m);
    for (int i = 0; i < n; i++) {
        scanf("%d%d", &w[i], &d[i]);
    }

    for (int i = 0; i < n; i++) {
        for (int j = m; j >= w[i]; j--) {
            //每放一件物品求出重量不大于w[j]时的最大价值
            int temp = dp[j - w[i]] + d[i];
            if (dp[j] < temp) {
                dp[j] = temp;
            }
        }
    }

    printf("%d\n", dp[m]);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值