【字典树】杭电1671 : Phone List

26 篇文章 0 订阅
12 篇文章 0 订阅



Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5747    Accepted Submission(s): 1973


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
  
  
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
  
  
NO YES
#include <stdio.h>

typedef struct NODE
{
    int flag; /* 标记是否是最后一个字母 */
    struct NODE *pNext[10];
}NODE,*PNODE;

NODE node[100100];
int ix_node = 0;

PNODE CreateNode()
{
    PNODE p = &node[ix_node++];
    int i;
    p->flag = 0; /* 不是最后一个字母 */

    for(i = 0 ; i < 10 ; ++i)
        p->pNext[i] = NULL;

    return p;
}

int Insert(PNODE *pRoot,char *s)
{
    PNODE p = *pRoot;
    int i,k;

    if(!p)
        p = *pRoot = CreateNode();

    i = 0;
    while(s[i])
    {
        k = s[i] - '0';

        if(s[i + 1]) /* 如果不是最后一个数字 */
        {
            if(!p->pNext[k])
            {
                p->pNext[k] = CreateNode();
            }
            else
            {
                if(1 == p->pNext[k]->flag) /* 有前缀了 */
                    return 0;
            }
        }
        else /* 当前数字已经是最后一个数了 */
        {
            if(p->pNext[k] != NULL) /* 当前串是前缀 */
                return 0;

            if(!p->pNext[k])
            {
                p->pNext[k] = CreateNode();
                p->pNext[k]->flag = 1; /* 设标记为1 */
            }
            else
            {
                if(1 == p->pNext[k]->flag) /* 有前缀了 */
                    return 0;
            }
        }

        p = p->pNext[k];
        ++i;
    }

    return 1;
}

void Delete(PNODE *pRoot)
{
    int i,j;
    for(i = 0 ; i < ix_node ; ++i)
    {
        for(j = 0 ; j < 10 ; ++j)
            node[i].pNext[j] = NULL;
    }

    ix_node = 0;
    *pRoot = NULL;
}

int main()
{
    int N,t;
    int IsOk = 1;
    char str[15];
    scanf("%d",&N);

    PNODE pRoot = NULL;

    while(N--)
    {
        scanf("%d",&t);
        while(t--)
        {
            scanf("%s",str);
            if(!Insert(&pRoot,str))
                IsOk = 0;
        }
        if(IsOk)
            printf("YES\n");
        else
            printf("NO\n");

        IsOk = 1;
        Delete(&pRoot);

    }

    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值