Red and Black
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 11711 Accepted Submission(s): 7289
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
Sample Output
45 59 6 13
解题报告:
很简单的一个深搜问题(dfs),记录 @ 的位置,直接在该位置的四个方向搜索,深度优先即可!
#include<cstdio>
#include<iostream>
using namespace std;
int cnt=0;
int n,m;
const int MAX=20+5;
char ch[MAX][MAX];
//bool visited[MAX][MAX];
void dfs(int x,int y){
if(x<0 || x>m-1 || y<0 || y>n-1) return;
if(ch[x][y]=='#') return;
else{
++cnt;
ch[x][y]='#';
dfs(x-1,y);
dfs(x+1,y);
dfs(x,y-1);
dfs(x,y+1);
}
}
int main(){
char c; int x,y;
while( ~scanf("%d%d",&n,&m) && n+m ){
cnt=0;
/*for(int ii=0;ii<MAX;++ii)
for(int jj=0;jj<MAX;++jj)
visited[ii][jj]=false;*/
for(int i=0;i<m;++i){
scanf("%c",&c);//读取掉每行最后的\n
for(int j=0;j<n;++j){
scanf("%c",&c);
if(c=='@'){x=i;y=j;ch[i][j]='.';}
else ch[i][j]=c;
}
}
dfs(x,y);
printf("%d\n",cnt);
}
return 0;
}