【HDU 5207】Greatest Greatest Common Divisor —— 最大公因子

14 篇文章 0 订阅

原题链接

Greatest Greatest Common Divisor

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 665    Accepted Submission(s): 298


Problem Description
Pick two numbers  ai,aj(ij)  from a sequence to maximize the value of their greatest common divisor.
 

Input
Multiple test cases. In the first line there is an integer  T , indicating the number of test cases. For each test cases, the first line contains an integer  n , the size of the sequence. Next line contains  n  numbers, from  a1  to  an 1T100,2n105,1ai105 . The case for  n104  is no more than  10 .
 

Output
For each test case, output one line. The output format is Case # x ans x  is the case number, starting from  1 ans  is the maximum value of greatest common divisor.
 

Sample Input
  
  
2 4 1 2 3 4 3 3 6 9
 

Sample Output
  
  
Case #1: 2 Case #2: 3





解题报告:

很水的一道题,竟然做了一天!摔!想的太多了,直接遍历就够了喂!当然遍历的时候要借用朴素筛法的思想,遍历到根号界就可以了,要不然肯定超时.......


#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
const int MAX=100000;
int a[MAX+10];
int main()
{
    int T,n,cnt=0,tmp,ans;
    cin>>T;
    while(T--)
    {
        memset( a,0,sizeof(a) );
        cin>>n;
        for(int i=0;i<n;++i){
            scanf("%d",&tmp);
            for(int j=1;tmp>=j*j;++j){
                if(tmp%j==0){++a[j]; if(j*j!=tmp) ++a[tmp/j];}
            }
        }
        for(ans=100000; ans>1 && a[ans]<2;--ans);
        printf("Case #%d: %d\n",++cnt,ans);
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值