1004 Counting Leaves(BFS)

1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

 这个题目的意思就是一个家庭的家族谱,一开始先是辈分最大的人 ,然后下面排着他的孩子,然后就这样一直排到最后的一辈(没有孩子)。这道题的输入是 输入N为总结点的数目,M为非叶子节点的数目,然后以下跟随M行,每行有一个ID K ID[1] ID[2] ... ID[K],id为这个非叶子节点的id,然后K为他的孩子数目,然后k个孩子的id,输入结束。输出:每一个辈分中有几个叶子节点。

光看这个,我们就想到BFS层次遍历寻找叶子节点,找出有多少辈分,然后输出各辈分的叶子节点。

#include<iostream>
#include<queue>
#include<bits/stdc++.h>
using namespace std;
const int maxn = 105;
struct node
{
	int level;
	int num;
	int child[maxn];
}dian[maxn];
int shu[maxn];

int solve()
{
	memset(shu, 0, sizeof(shu));
	queue<node>q;
	dian[1].level = 0;

	q.push(dian[1]);			//一开始根节点就是01 ,就是1
	int maxlevel=-1;

	while (!q.empty())
	{
		node t = q.front();
		q.pop();
		maxlevel = max(maxlevel, t.level);
		if (!t.num)
			++shu[t.level];
		else
		{
			for (int i = 0; i < t.num; i++)
			{
				dian[ t.child[i] ].level = t.level + 1;
				q.push( dian[t.child[i]] );
			}
		}
	}
	return maxlevel;
}


int main()
{
	int n, m;
	cin >> n >> m;
	int id, t;
	for (int i = 0; i < m; i++)
	{
		cin >> id >> t;
		dian[id].num = t;
		for (int j = 0; j < t; j++)
			cin >> dian[id].child[j];        //直接id 当作下标,直接将所有的节点都装进去了
										 //后面直接插入就行
	}
	int maxlevel = solve();
	for (int i = 0; i <= maxlevel; i++)
	{
		if (i)
			cout << ' ';
		cout << shu[i];

	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
目标检测(Object Detection)是计算机视觉领域的一个核心问题,其主要任务是找出图像中所有感兴趣的目标(物体),并确定它们的类别和位置。以下是对目标检测的详细阐述: 一、基本概念 目标检测的任务是解决“在哪里?是什么?”的问题,即定位出图像中目标的位置并识别出目标的类别。由于各类物体具有不同的外观、形状和姿态,加上成像时光照、遮挡等因素的干扰,目标检测一直是计算机视觉领域最具挑战性的任务之一。 二、核心问题 目标检测涉及以下几个核心问题: 分类问题:判断图像中的目标属于哪个类别。 定位问题:确定目标在图像中的具体位置。 大小问题:目标可能具有不同的大小。 形状问题:目标可能具有不同的形状。 三、算法分类 基于深度学习的目标检测算法主要分为两大类: Two-stage算法:先进行区域生成(Region Proposal),生成有可能包含待检物体的预选框(Region Proposal),再通过卷积神经网络进行样本分类。常见的Two-stage算法包括R-CNN、Fast R-CNN、Faster R-CNN等。 One-stage算法:不用生成区域提议,直接在网络中提取特征来预测物体分类和位置。常见的One-stage算法包括YOLO系列(YOLOv1、YOLOv2、YOLOv3、YOLOv4、YOLOv5等)、SSD和RetinaNet等。 四、算法原理 以YOLO系列为例,YOLO将目标检测视为回归问题,将输入图像一次性划分为多个区域,直接在输出层预测边界框和类别概率。YOLO采用卷积网络来提取特征,使用全连接层来得到预测值。其网络结构通常包含多个卷积层和全连接层,通过卷积层提取图像特征,通过全连接层输出预测结果。 五、应用领域 目标检测技术已经广泛应用于各个领域,为人们的生活带来了极大的便利。以下是一些主要的应用领域: 安全监控:在商场、银行
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值