pat 1069. The Black Hole of Numbers

原题链接:https://www.patest.cn/contests/pat-a-practise/1069


      1069. The Black Hole of Numbers (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the "black hole" of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation "N - N = 0000". Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:
6767
Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
Sample Input 2:
2222
Sample Output 2:
2222 - 2222 = 0000


怎么写都有一个实例错误,求大神帮忙找找吧。。


// pat_The Black Hole of Numbers.cpp : 定义控制台应用程序的入口点。
//

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>

using namespace std;

int a[5], b[5];

int main(int argc, char* argv[])
{
	int n, i, j;
	scanf("%d", &n);
	int m = n;
	i = 0;
	while (n){
		a[i] = n % 10;
		n /= 10;
		i++;
	}
	for (i = 0; i < 3; i++)
	{
		if (a[i] != a[i + 1])
			break;
	}
	if (i >= 3)
	{
		printf("%04d - %04d = 0000\n", m, m);
		return 0;
	}
	sort(a, a + 4);
	for (i = 0; i < 4; i++)
		b[i] = a[4 - i - 1];
	while (1)
	{
		int sum1 = 0, sum2 = 0, sum;
		for (i = 0; i < 4; i++)
			sum1 = sum1 * 10 + b[i];
		for (i = 0; i < 4; i++)
			sum2 = sum2 * 10 + a[i];
		sum = sum1 - sum2;
		printf("%04d - %04d = %04d\n", sum1, sum2, sum);
		if (sum == 6174 || sum == 0)
			break;
		i = 0;
		while (sum)
		{
			a[i] = sum % 10;
			i++;
			sum /= 10;
		}
		sort(a, a + 4);
		for (i = 0; i < 4; i++)
			b[i] = a[3 - i];
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值