PAT 数据结构 03-树3. Tree Traversals Again (25)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1
/*2015.7.8*/
//03-3 先根遍历创建树,使用指针的引用和迭代器的引用,递归
#include <iostream>
#include <math.h>
#include <vector>
#include <queue>
#include <string>
using namespace std;

struct TNode{
	int val;
	TNode* left;
	TNode* right;
	TNode(int x):val(x),left(nullptr),right(nullptr){}
};
void createTree(TNode *&root,vector<int>::iterator &it){
	if((*it)==0){
		root=nullptr;
		it++;
	}else{//数据不为0,root指针指向一个new的结点
		root=new TNode(*it);
		it++;
		createTree(root->left,it);
		createTree(root->right,it);
	}
}
void postOrder(TNode *&root,vector<int> &result){
	if(root!=nullptr){
		postOrder(root->left,result);
		postOrder(root->right,result);
		result.push_back(root->val);
	}
}
int main(){
	int N;
	cin>>N;
	N=2*N;
	string s;
	int x;
	vector<int> seq(N+1);
	for(int i=0;i<N;i++){
		cin>>s;
		if(s=="Push"){
			cin>>x;
			seq[i]=x;
		}else
			seq[i]=0; //0表示NULL
	}
	seq[N]=0;
	vector<int>::iterator it=seq.begin();
	TNode* root;
	createTree(root,it);
	vector<int> result;
	postOrder(root,result);
	int n=result.size();
	cout<<result[0];
	for(int i=1;i<n;i++)
		cout<<" "<<result[i];
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值