03-树3 Tree Traversals Again(25 分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

Figure 1
Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1


注意的地方:

三种非递归pushpop
先序先序中序
中序先序中序
后序先序后序

push和pop的数字序列,后序是使用标记变量来实现的。

所以题目中push就是先序,pop就是中序,因此可以唯一确定后序。

依照递归来实现,ipush用来确定root,iin确定新的左子树个数,ipost确定偏移量(到底是哪一块的最后一个)。

#include <iostream>
#include <stack>
#define MAXSIZE 30
//#define LOCAL
int push[MAXSIZE];
int inOrder[MAXSIZE];
int post[MAXSIZE];
void fuc(int ipush, int iin, int ipost, int num);
int main()
{
#ifdef LOCAL
    freopen("test.txt", "r", stdin);
#endif
    int N;
    char input[5];
    std::stack<int> s;
    std::cin >> N;
    int index_push = 0, index_in = 0;
    for(int i=0; i<2*N; ++i) {
        scanf("%s", input);
        int data;
        if(input[1]=='u') {
            std::cin >> data;
            push[index_push++]= data;
            s.push(data);
        }
        else {
            inOrder[index_in++] = s.top();
            s.pop();
        }
    }
    fuc(0,0,0,N);
    for(int i=0; i<N; ++i) {
        if(i) std::cout << ' ';
        std::cout << post[i];
    }
}

void fuc(int ipush, int iin, int ipost, int num) {
    if(!num) return;
    if(num == 1) {
        post[ipost] = inOrder[iin];
        return;
    }
    int root = push[ipush];
    //ipost是offset
    post[ipost+num-1] = root;
    int i, L, R;
    for(i=0; i<num; ++i) {
        if(inOrder[iin + i]==root) break;
    }
    L = i; //左子树个数
    R = num - i - 1; //右子树个数
    fuc(ipush + 1, iin, ipost, L);
    //         前   左      左   前   偏移量更新L
    fuc(ipush + 1 + L, iin + L + 1, ipost + L, R);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值