PAT 数据结构 08-排序5. Sort with Swap(0,*) (25)

Given any permutation of the numbers {0, 1, 2,..., N-1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (<=105) followed by a permutation sequence of {0, 1, ..., N-1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:
10 3 5 7 2 6 4 9 0 8 1
Sample Output:
9
/*2015.7.14cyq*/
#include <iostream>
#include <vector>
using namespace std;
//有两种环,一种含关键数0,一种不含(需要多出破环和补环两次操作)
int main(){
	int N;
	cin>>N;
	vector<int> a(N);
	for(int i=0;i<N;i++)
		cin>>a[i];
	vector<bool> used(N,false);
	//0与count个数连成一个环,count次交换后0回到a[0],其它数位置均正确
	int next=0;
	int count=0;
	while(a[next]!=0){
		next=a[next];
		used[next]=true;
		count++;
	}
	
	//非0的K个数连成一个环,共K+1次操作:0与环中任意一个数交换,环K-1次交换,补环(0回到a[0])
	int K;
	int begin;
	int t;
	for(int i=1;i<N;i++){
		if(!used[i]&&a[i]!=i){//没用过且放错位置的数,说明是一个新环
			used[i]=true;
			K=1;
			begin=i;
			t=i;
			while(a[t]!=begin){
				t=a[t];
				used[t]=true;
				K++;
			}
			count=count+K+1;
		}
	}
	cout<<count;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值