PAT (Advanced Level) 1025. PAT Ranking (25) 结构体排序

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
结构体排序。
/*2015.7.22cyq*/
#include <iostream>
#include <vector>
#include <string>
#include <algorithm>
#include <fstream>
using namespace std;

//ifstream fin("case1.txt");
//#define cin fin

struct stu{
	string id;		//id
	int score;		//分数
	int finalRank;	//总排名
	int locationNum;//考场号
	int localRank;	//考场排名
	stu(string ID,int sco,int fr,int ln,int lr):id(ID),score(sco),finalRank(fr),
		locationNum(ln),localRank(lr){}

	bool operator < (const stu &a)const{
		if(score>a.score)
			return true;
		else if(score==a.score&&id<a.id)
			return true;

		return false;
	}
};

int main(){
	int N,K;
	cin>>N;
	vector<vector<stu> > r(N);//r[i]表示i-1号考场
	string id;
	int sco;
	for(int i=0;i<N;i++){
		cin>>K;
		for(int j=1;j<=K;j++){
			cin>>id>>sco;
			r[i].push_back(stu(id,sco,0,i+1,0));
		}
		sort(r[i].begin(),r[i].end());
	
		int rank=1;
		r[i][0].localRank=1;
		for(int j=1;j<K;j++){
			if(r[i][j].score<r[i][j-1].score){//新的分数,更新排名,否则并列
				rank=j+1;
			}
			r[i][j].localRank=rank;
		}
	}
	vector<stu> result;
	for(auto it=r.begin();it!=r.end();it++){
		for(auto itt=(*it).begin();itt!=(*it).end();itt++){
			result.push_back(*itt);
		}
	}
	sort(result.begin(),result.end());
	int len=result.size();
	int rank=1;
	result[0].finalRank=1;
	for(int i=1;i<len;i++){
		if(result[i].score<result[i-1].score)
			rank=i+1;
		result[i].finalRank=rank;
	}
	cout<<len<<endl;
	for(int i=0;i<len;i++){
		cout<<result[i].id<<" "<<result[i].finalRank<<" "<<result[i].locationNum<<" "<<result[i].localRank<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值