PAT (Advanced Level) 1038. Recover the Smallest Number (30) 串联最小字符串,排序

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Do not output leading zeros.

Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287
字符串排序。将这些整数看成字符串,要把这些字符串串联起来得到最小的字符串。
由于高位权重较大,故前缀越小的字符串越应该放前面。
所有字符串串联起来后,在整串中,对于任意两个字符串s1和s2,有两种情况:***s1%%%s2###或***s2%%%s1###。
我们可以直接比较s1+s2和s2+s1。若s1+s2<s2+s1,即两个字符串串联时,s1放前面得到的字符串较小,说明他们放到整串中时,s1也应该放s2前面,即***s1%%%s2###小于***s2%%%s1###。
故我们可以直接对所有字符串从小到大排序。
输出时注意去掉第一个非全0字符串前面的0,若全为全0字符串则输出0。
/*2015.7.24cyq*/
#include <iostream>
#include <vector>
#include <string>
#include <sstream>
#include <algorithm>
using namespace std;

int str2int(const string s1){
	stringstream ss;
	ss<<s1;
	int k;
	ss>>k;
	return k;
}

bool cmp(const string s1,const string s2){
	return s1+s2<s2+s1;
}

int main(){
	int N;
	cin>>N;
	vector<string> a;
	string s;
	for(int i=0;i<N;i++){
		cin>>s;
		a.push_back(s);
	}
	sort(a.begin(),a.end(),cmp);
	int k=0;
	while(k<N&&(str2int(a[k])==0))//去掉所有全0的片段
		 k++;
	if(k==N){
		cout<<0;
		return 0;
	}
	if(k<N){//第一个不是全0的片段,若前面有0需去掉
		int len=a[k].size();
		int i=0;
		while(a[k][i]=='0')
			i++;
		while(i<len){
			cout<<a[k][i];
			i++;
		}
		k++;
	}
	while(k<N){
		cout<<a[k];
		k++;
	}
	return 0;
}


ECDSA.recover is a function in the ECDSA (Elliptic Curve Digital Signature Algorithm) cryptographic system that allows a user to recover the public key from a given signature and message. This function is useful in situations where the public key is unknown but the signature and message are available. The ECDSA algorithm involves three steps: key generation, signature generation, and signature verification. In the key generation step, a private key is generated using a random number generator, and the corresponding public key is derived from the private key. In the signature generation step, a message is hashed and signed using the private key to generate a signature. In the signature verification step, the signature is verified using the public key to ensure that it was generated by the owner of the private key. In some cases, the public key may not be available, but the signature and message are known. In such cases, the ECDSA.recover function can be used to recover the public key from the signature and message. The function takes three inputs: the message, the signature, and the recovery parameter. The recovery parameter is a number between 0 and 3 that specifies which of the four possible public keys should be recovered from the signature. Once the public key is recovered, it can be used to verify the signature and authenticate the message. Overall, ECDSA.recover is a useful function in the ECDSA cryptographic system that allows for public key recovery in situations where it is unknown but the signature and message are available.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值