PAT (Advanced Level) 1093. Count PAT's (25) 一维动态规划

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 105characters containing only P, A, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:
APPAPT
Sample Output:
2
计算有多少对PAT,只要一遍扫描即可,O(N)。用一个变量记录当前位置之前有多少对PA,这样遇到T的时候前面的PA数目就是新增的PAT数目。由于遇到A的时候PA的数目可能会增加,还需要用一个变量记录当前位置之前有多少个P,遇到A的时候前面P的数目就是新增的PA数目。
用long long记录总数避免溢出。
/*2015.7.31cyq*/
#include <iostream>
#include <vector>
#include <string>
using namespace std;

int main(){
	string s;
	cin>>s;
	long long count=0;//总PAT数
	int PA=0;  //前面的PA数目
	int P=0;   //前面的P数目
	int n=s.size();
	for(int i=0;i<n;i++){
		if(s[i]=='T')
			count+=PA;
		else if(s[i]=='A')
			PA+=P;
		else if(s[i]=='P')
			P++;
	}
	cout<<count%1000000007;
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值