Hdu-1005 Number Sequence

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 217350    Accepted Submission(s): 55023


 

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

 

 

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

 

 

Output

For each test case, print the value of f(n) on a single line.

 

Sample Input
1 1 3
1 2 10
0 0 0


Sample Output
2
5

算完所有可能出现的49种情况,由f[n%49]得出所要计算的f[n]

ac代码:

#include <iostream>
#define N 60
using namespace std;
int f[N+1];
int a,b,n;

int main()
{
    
    while((cin>>a>>b>>n)&&a|b|n) {
        f[1] = 1;
        f[2] = 1;
        if(n==1&&n==2){
            cout<<f[n]<<endl;
        }else{
            //在这里可以加上一个n是否小于的50的判断,如果n小于50直接计算到n就可以了,是一个小小的优化,,
            for(int i=3;i<50;i++){
                f[i] = (a*f[i-1]+b*f[i-2])%7;
            }
            cout<<f[n%49]<<endl;
        }
    }
    return 0;
}

 

参考链接

分析与题解1

分析与题解2

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值