Hdu-1004 Let the Balloon Rise

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 159698    Accepted Submission(s): 63511


 

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

 

 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

 

 

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

 

 
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
 

Sample Output
red
pink

 

这里我偷懒使用map数据结构进行操作,map<string,int> string记录的是气球的名称,int 记录的是气球出现的次数

 

ac代码:

#include <iostream>
#include <map>
using namespace std;
int n;
map<string,int> ballons;


int main()
{
    while(cin>>n&&n!=0){
        for(int i=0;i<n;i++){
            string bname;
            cin>>bname;
            ballons[bname]++;
        }

        int max = 0;
        string mostPopularBname;
        map<string,int>::iterator iter;
        for(iter = ballons.begin();iter!=ballons.end();iter++){
            if(max<iter->second){
                mostPopularBname = iter->first;
                max = iter->second;
            }
        }
        cout<<mostPopularBname<<endl;
        ballons.clear();
    }

    return 0;
}

附加一份写的不错的关于C++ map数据结构使用方面的博客

C++中的STL中map用法详解

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值