Hdu-1008 Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 92715    Accepted Submission(s): 50455


 

Problem Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

 

 

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

 

 

Output

Print the total time on a single line for each test case.

 

Sample Input
1 2
3 2 3 1
0


Sample Output
17
41

 

这题刚开始看到所有输入都小于100,很乐观的开了一个101个int单位长度的数组,然后很自然的wa了~ ~

看了一下网上的一个代码用的递推法,逻辑都一样,我想可能问题就是出在这了,改成了递推法,过了,,

 

ac代码

#include <iostream>
using namespace std;
int m_up = 6; //上升所用的时间
int m_dw = 4; //下降所有的时间
int m_st = 5; //停止所用的时间
int N;

int main()
{
    while(cin>>N&&N!=0){
        int now_stair = 0; //现在所在的层数
        int all_time = 0; //总时长
        int get_floor;
        for(int i=0;i<N;i++){
            cin>>get_floor; //获取输入的楼层数
            if(get_floor>now_stair){
                all_time+=m_up*(get_floor-now_stair);
            }else if(get_floor<now_stair){
                all_time+=m_dw*(now_stair-get_floor);
            }
            now_stair = get_floor;
            all_time+=m_st;
        }
        cout<<all_time<<endl;
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值