sdut oj 2404 super prime(素数筛)

题目链接:点击打开链接

题目大意:

We all know, prime is a kind of special number which has no other factors except of 1 and itself.
2,3,5,7,11,13,17,19,23,29 are the top 20 primes.
Now there is a new question about prime:
We call a prime as super prime when and only when which can be represented as the sum of multiple continuous primes. For example: 5=2+3, so 5 is a super prime.
Please program to judge whether a number is a super prime or not.

输入

The first line is an integer T (T<=1000), and then T lines follow.
There is only one positive integer 
N(1<N<100000).

输出

For each case you should output the case number first, and then the word "yes" if the integer N is a super prime, and you should output "no" otherwise.

示例输入

3
5
7
8

示例输出

Case 1: yes
Case 2: no
Case 3: no
来源:山东省赛(第三届)(热身赛)

代码:

///Super Prime
#include <iostream>
#include<cmath>
#include<cstring>
#include<cstdio>

using namespace std;

int main()
{
    int h=100100;
    int q[100100];
    memset(q,0,sizeof(q));
    q[0]=q[1]=1;
    int w=sqrt((double)h)+1;
    int p,t,k;
    for( p=2; p<=w; p++)
    {
        if(q[p]==0)
        {
            for(t=p; t*p<=h; ++t)
            {
                if(q[t]==0)
                {
                    for(k=p*t; k<=h; k*=p)
                    {
                        q[k]=1;
                    }
                }
            }
        }
    }
    int y[10000];
    int top=0;
    for(int i=0; i<=h; i++)
    {
        if(q[i]==0) y[top++]=i;
    }
    int x,n;
    cin>>x;
    for(int i=1; i<=x; i++)
    {
        cin>>n;
        if(q[n]==1||n==2||n==3||n==7)
        {
            printf("Case %d: no\n",i);
        }
        else
        {
            for(int j=0;j<top;j++)
            {
                if(y[j]==n)
                {
                    p=j;
                    break;
                }
            }
            int front=p ,back=p;
            int sum=0;
            front--;
            back--;
            back--;
            sum=sum+y[front];
            sum=sum+y[back];
            int f=0;
            while(1)
            {
                if(sum>n)
                {
                    sum=sum-y[front];
                    front--;
                    if(back==front)
                    {
                        if(back==0)
                        {
                            f=0;
                            break;
                        }
                        back--;
                        sum=sum+y[back];
                    }
                }
                if(sum==n)
                {
                    f=1;
                    break;
                }
                else
                {
                    if(back==0)
                    {
                        f=0;
                        break;
                    }
                    back--;
                    sum=sum+y[back];
                }
            }
            if(f==0)printf("Case %d: no\n",i);
            else printf("Case %d: yes\n",i);
        }

    }
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
SDUT-OJ(Software Development University of Tsinghua Online Judge)是一个在线编程平台,提供给清华大学软件学院的学生和爱好者练习和解决算法问题的环境,其中包括各种计算机科学题目,包括数据结构、算法、图形等。对于"最小生成树"(Minimum Spanning Tree, MST)问题,它是图论中的经典问题,目标是从一个加权无向图中找到一棵包含所有顶点的树,使得树的所有边的权重之和最小。 在C语言中,最常见的是使用Prim算法或Kruskal算法来求解最小生成树。Prim算法从一个顶点开始,逐步添加与当前生成树相连且权重最小的边,直到所有顶点都被包含;而Kruskal算法则是从小到大对所有边排序,每次选取没有形成环的新边加入到树中。 如果你想了解如何用C语言实现这些算法,这里简单概括一下: - 通常使用优先队列(堆)来存储边和它们的权重,以便快速查找最小值。 - 从任意一个顶点开始,遍历与其相邻的边,若新边不形成环,就更新树,并将新边加入优先队列。 - Kruskal算法: - 先将所有的边按照权重升序排序。 - 创建一个空的最小生成树,然后依次取出排序后的边,如果这条边连接的两个顶点不在同一个连通分量,则将其添加到树中。 如果你需要更详细的代码示例,或者有具体的问题想了解(比如如何处理环、如何实现优先队列等),请告诉我,我会为你提供相应的帮助。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值