poj 1850 Code

题目链接:点击打开链接

Description

Transmitting and memorizing information is a task that requires different coding systems for the best use of the available space. A well known system is that one where a number is associated to a character sequence. It is considered that the words are made only of small characters of the English alphabet a,b,c, ..., z (26 characters). From all these words we consider only those whose letters are in lexigraphical order (each character is smaller than the next character). 

The coding system works like this: 
• The words are arranged in the increasing order of their length. 
• The words with the same length are arranged in lexicographical order (the order from the dictionary). 
• We codify these words by their numbering, starting with a, as follows: 
a - 1 
b - 2 
... 
z - 26 
ab - 27 
... 
az - 51 
bc - 52 
... 
vwxyz - 83681 
... 

Specify for a given word if it can be codified according to this coding system. For the affirmative case specify its code. 

Input

The only line contains a word. There are some constraints: 
• The word is maximum 10 letters length 
• The English alphabet has 26 characters. 

Output

The output will contain the code of the given word, or 0 if the word can not be codified.

Sample Input

bf

Sample Output

55
题目大意:输出某个str字符串在字典中的位置,由于字典是从a=1开始的,因此str的位置值就是 在str前面所有字符串的个数 +1
规定输入的字符串必须是升序排列。不降序列是非法字符串
不要求用循环输入去输入若干组字符串,但若输入非法字符串则输出0,且结束程序,
本题Str最长为10个字符

ps:(转载的,比较详细点)

组合数学题,不知道为什么会被归类到递推数学,可能是因为杨辉三角和组合数之间的关系。。。

 

第一步当然首先判断输入的str是否是升序序列

 

若符合第一步,则首先计算比str长度少的所有字符串个数

假设str vwxyz ,则其长度为5

那么


 

  然后就是关键了,长度为2的字符串,根据开头字母不同,就有25种不同情况,编程去处理是很困难的。这里必须要用数学方法去处理。



 

所以用一个简单的循环就能计算出 str长度少的所有字符串个数 了,这就是数学的威力,把受限的取法转换为不限制的取法

 

 

第三步,就是求长度等于str,但值比str 小的字符串个数

这个看我程序的注释更容易懂,所以这里就不再啰嗦了,值得注意的是这步我同样利用了公式(1,所以如果看到某些地方取字母的时候看上去好像没有遵守“升序规则”,本来要限制取字母的地方却没有限制,那一定是用公式(1)变换了

 

第四步,把前面找到的所有字符串的个数之和再+1,就是str的值

之所以+1,是因为此前的所有操作都只是找str之前的字符串,并不包括str本身

 

然后到了最后,剩下一个问题就是怎样得到每一个 的值,这个我发现很多同学都是利用打表做的,利用的就是 组合数  杨辉三角 的关系(建立一个二维数组C[n]

就能看到他们之间关系密切啊!区别就是顶点的值,杨辉三角为1,组合数为0

其实这个“关系”是有数学公式的

#include <iostream>
#include<cstring>

using namespace std;
int c[30][30];
int main()
{
    ///打表计算组合数(利用组合与杨辉三角的关系)
    for(int i=0;i<=26;i++)
    {
        for(int j=0;j<=i;j++)
        {
            if(!j||i==j)c[i][j]=1;
            else c[i][j]=c[i-1][j-1]+c[i-1][j];
        }
    }
    c[0][0]=0;
    char str[15];
    while(cin>>str)
    {
        int len=strlen(str);
        ///判断字符串是否升序
        for(int i=1;i<len;i++)
        {
            if(str[i-1]>=str[i])
            {
                cout<<"0\n";
                return 0;
            }
        }
        int sum=0;
        ///将小于字符串长度的加和
        for(int i=1;i<len;i++)
        {
            sum+=c[26][i];
        }
        char ch;
        ///等长的加和
        for(int i=0;i<len;i++)
        {
            if(i==0)ch='a';
            else ch=str[i-1]+1;///ch = str[i-1]+1 根据升序规则,当前位置的ch至少要比str前一位置的字符大
            while(ch<=str[i]-1)///ch<=str[i]-1 根据升序规则,当前位置的ch最多只能比 str这个位置实际上的字符 小1
            {
                sum+=c['z'-ch][len-1-i];///'z'-ch : 小于等于ch的字符不允许再被选择,所以当前能够选择的字符总数
                ch++;
            }
        }
        cout<<++sum<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值