poj 1265 Area

Description

Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor抯 agent could find is the fact that the robots radio their movements unencrypted. Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight walls are used. Figure 1 shows the course of a robot around an example area. 

 
Figure 1: Example area. 

You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that simple formula for you, so your first task is to find the formula yourself. 

Input

The first line contains the number of scenarios. 
For each scenario, you are given the number m, 3 <= m < 100, of movements of the robot in the first line. The following m lines contain pairs 揹x dy�of integers, separated by a single blank, satisfying .-100 <= dx, dy <= 100 and (dx, dy) != (0, 0). Such a pair means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100 units. 

Output

The output for every scenario begins with a line containing 揝cenario #i:� where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point. Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.

Sample Input

2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3

Sample Output

Scenario #1:
0 4 1.0

Scenario #2:
12 16 19.0

给一个平面上的简单多边形,求边上的点,多边形内的点,多边形面积。
解题思路:
这个题用了很多知识点:
1、以格子点为顶点的线段,覆盖的点的个数为GCD(dx,dy),其中,dxdy分别为线段横向占的点数和纵向占的点数。如果dx或dy为0,则覆盖的点数为dy或dx。
2、Pick公式:平面上以格子点为顶点的简单多边形的面积=边上的点数/2+内部的点数+1。
3、任意一个多边形的面积等于按顺序求相邻两个点与原点组成的向量的叉积之和。



要注意他每次给出的点并不是点的横纵坐标,
而是相对于上一个点的横纵坐标离开的距离dx,dy,

所以你还要求一下每个点的坐标,然后再进行别的操作就可以了

(这个题不是自己写出来的,做了3天没做出来,本来在训练指南书上看到一个求点在多边形内的判定的算法 但是写上之后运行不对,有想到根据面积暴力每个点,结果也不对

然后看了一下大神们的代码后,发现涉及到的知识点都回,pick定理还有gcd(dx,dy)求覆盖点,而且也把题意理解错了,其实人家输入的并不是点集,惭愧啊,太菜了。不过学会了两个知识点,也算有收获,嘎嘎~)


#include <iostream>
#include<cstdio>
#include<cstring>
#define eps 1e-10
#include<cmath>

using namespace std;

struct node
{
    int x,y;

}point[110];

int n;

int gcd(int a,int b)
{
    return b?gcd(b,a%b):a;
}

int Area (node a,node b)
{
    return a.x*b.y-a.y*b.x;
}
int main()
{
    int t,c=0;
    cin>>t;
    while(t--)
    {
        int a=0,p=0,dx,dy;
        cin>>n;
        point[0].x=0;
        point[0].y=0;
        for(int i=1;i<=n;i++)
        {
            cin>>point[i].x>>point[i].y;
            dx=point[i].x;
            if(dx<0)dx=-dx;
            dy=point[i].y;
            if(dy<0)dy=-dy;
            p+=gcd(dx,dy);
            point[i].x+=point[i-1].x;
            point[i].y+=point[i-1].y;
            a+=Area(point[i],point[i-1]);///第三点为原点(0,0),相当于是向量
        }
        if(a<0)a=-a;
        printf("Scenario #%d:\n",++c);
        printf("%d %d %.1lf\n\n",(a-p+2)/2,p,0.5*a);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值