POJ3321——Apple Tree(DFS+树状数组)

Apple Tree
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 19110 Accepted: 5816

Description

There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won't grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
"x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
"x" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2

题意:
在一棵树上,每个分叉点及末梢可能有苹果(最多1个), 每次可以摘掉一个苹果,或有一个苹果新长出来,随时查询某个分叉点往上的子树里,一共有多少个苹果。(分叉点数<100,000) 
根据题意,一开始时,所有能长苹果的地方都有苹果。


分析:
具体做法是做一次dfs,记下每个节点的开始时间Start[i]和结 束时间End[i],那么对于i节点的所有子孙的开始时间和结束时间都应位于Start[i]和End[i]之间然后用树状数组统计Start[i]到End[i]之间的附加苹果总数。 
这里用树状数组统计区间可以用Sum(End[i])-Sum(Start[i]-1)来计算。 


但是这道题比较坑的地方是会卡Vector邻接表,但是换一种写法也能过,不知道为毛!


Vector邻接表版    938MS

#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <vector>
#define INF 0x7fffffff
using namespace std;

const int N = 100000 + 10;

vector<vector<int> > G(N);
//vector<int> G[N];  为毛这样写就TLE!

int Start[N],End[N];
int a[N],Time;
bool Have[N];

void init()
{
    Time=0;
    for(int i=0; i<N; i++)
    {
        G[i].clear();
        Have[i]=true;
    }
}
int lowbit(int x)
{
    return x&-x;
}
void add(int x,int v)
{
    for(int i=x; i<N; i+=lowbit(i))
        a[i]+=v;
}
int getsum(int x)
{
    int ret=0;
    for(int i=x; i>0; i-=lowbit(i))
        ret+=a[i];
    return ret;
}
void dfs(int u)
{
    Time++;
    Start[u]=Time;
    for(int i=0; i<G[u].size(); i++)
        dfs(G[u][i]);
    End[u]=Time;
}

int main()
{
    int n,m;
    while(~scanf("%d",&n))
    {
        init();
        for(int i=0; i<n-1; i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            G[a].push_back(b);
        }
        
        dfs(1);
        for(int i=1; i<=n; i++) //初始化树上苹果
            a[i]=lowbit(i);

        scanf("%d",&m);
        while(m--)
        {
            char s[3];
            int x;
            scanf("%s%d",s,&x);
            if(s[0]=='Q')
            {
                int ans=getsum(End[x])-getsum(Start[x]-1);
                printf("%d\n",ans);
            }
            else if(s[0]=='C')
            {
                if(Have[x])
                    add(Start[x],-1);
                else
                    add(Start[x],1);

                Have[x]^=1;
            }
        }
    }
    
    return 0;
}

手写邻接表 391MS C++

#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <vector>
#define INF 0x7fffffff
using namespace std;

const int N = 100000 + 10;

int Start[N],End[N];
int a[N],Time;
bool Have[N];

struct Edge
{
    int v,next;
}e[N];
int head[N],top=0;

void Add_edge(int u,int v)
{
    e[top].v=v;
    e[top].next=head[u];
    head[u]=top++;
}

void dfs(int u)
{
    Time++;
    Start[u]=Time;
    for(int i=head[u]; i!=-1; i=e[i].next)
        dfs(e[i].v);
    End[u]=Time;
}

int lowbit(int x)
{
    return x&-x;
}
void add(int x,int v)
{
    for(int i=x; i<N; i+=lowbit(i))
        a[i]+=v;
}
int getsum(int x)
{
    int ret=0;
    for(int i=x; i>0; i-=lowbit(i))
        ret+=a[i];
    return ret;
}

void init()
{
    Time=0;
    top=0;
    memset(Have,1,sizeof(Have));
    memset(head,-1,sizeof(head));
}

int main()
{
    int n,m;
    while(~scanf("%d",&n))
    {
        init();
        for(int i=0; i<n-1; i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            Add_edge(a,b);
        }

        dfs(1);
        for(int i=1; i<=n; i++) //初始化树上苹果
            a[i]=lowbit(i);

        scanf("%d",&m);
        while(m--)
        {
            char s[3];
            int x;
            scanf("%s%d",s,&x);
            if(s[0]=='Q')
            {
                int ans=getsum(End[x])-getsum(Start[x]-1);
                printf("%d\n",ans);
            }
            else if(s[0]=='C')
            {
                if(Have[x])
                    add(Start[x],-1);
                else
                    add(Start[x],1);

                Have[x]^=1;
            }
        }
    }

    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ 2182是一道使用树状数组解决的题目,题目要求对给定的n个数进行排序,并且输出每个数在排序后的相对位置。树状数组是一种用来高效处理前缀和问题的数据结构。 根据引用中的描述,我们可以通过遍历数组a,对于每个元素a[i],可以使用二分查找找到a到a[i-1]中小于a[i]的数的个数。这个个数就是它在排序后的相对位置。 代码中的query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。 最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。 参考代码如下: ```C++ #include <iostream> #include <cstdio> using namespace std; int n, a += y; } } int main() { scanf("%d", &n); f = 1; for (int i = 2; i <= n; i++) { scanf("%d", &a[i]); f[i = i & -i; } for (int i = n; i >= 1; i--) { int l = 1, r = n; while (l <= r) { int mid = (l + r) / 2; int k = query(mid - 1); if (a[i > k) { l = mid + 1; } else if (a[i < k) { r = mid - 1; } else { while (b[mid]) { mid++; } ans[i = mid; b[mid = true; add(mid, -1); break; } } } for (int i = 1; i <= n; i++) { printf("%d\n", ans[i]); } return 0; } ``` 这段代码使用了树状数组来完成题目要求的排序功能,其中query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *3* [poj2182Lost Cows——树状数组快速查找](https://blog.csdn.net/aodan5477/article/details/102045839)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] - *2* [poj_2182 线段树/树状数组](https://blog.csdn.net/weixin_34138139/article/details/86389799)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值