【二分】Solve It

Problem F

Solve It

Input: standard input

Output: standardoutput

Time Limit: 1 second

Memory Limit: 32 MB

Solve the equation:
        p*e-x+ q*sin(x) + r*cos(x) + s*tan(x)+ t*x2 + u = 0
        where 0 <= x <= 1.

Input

Input consists of multiple test cases and terminated by an EOF. Each testcase consists of 6 integers in a single line: p,q, r, s, tand u (where 0 <= p,r <= 20 and -20<= q,s,t<= 0). There will be maximum 2100 lines in the input file.

Output

For each set of input, there should be a line containing the value of x, correct upto 4 decimal places,or the string "No solution",whichever is applicable.

Sample Input

0 0 0 0 -2 1
1 0 0 0 -1 2
1 -1 1 -1 -1 1

Sample Output

0.7071
No solution
0.7554

Mustaq Ahmed


f(x)在[0,1]上单调递减。

所有有唯一解的充要条件是f(0)>0 且 f(1)<0。

利用单调性,可以用二分解决。


注意f的精度不能代替x的精度。而式子比较复杂,难以分析为了使x的精度达到要求f的精度要求。

我误以为f的精度可以代替x的精度,划分10^6个区间,时间复杂度是lg(n),10^6未免太抠门,不妨迭代100次,精度肯定能达到要求。


#include <cstdio>
#include <cmath>

const double eps = 1e-8;

int p,q,r,s,t,u;

double f(double x)
{
	return exp(-x)*p+sin(x)*q+cos(x)*r+tan(x)*s+x*x*t+u;
}


int main()
{
	while (scanf("%d%d%d%d%d%d",&p,&q,&r,&s,&t,&u)!=EOF)
	{
		if (f(0) < -eps || f(1) > eps)
		{
			printf("No solution\n");
			continue;
		}

		double l = 0;
		double r = 1;
		double ff;

		double x;
		for (int i=0;i<100;i++)
		{
			x = (l+r)/2.0;
			ff = f(x);
		//	printf("%lf %lf\n",x,ff);
			if (ff < -eps)
				r = x;
			else if (ff > eps)
				l = x;
			else
				break;
		}

		printf("%.4lf\n",x);
	}
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值