HOJ 2685 POJ 2777 Count Color

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board:

1. "C A B C" Color the board from segment A to segment B with color C.

2. "P A B" Output the number of different colors painted between segment A and segment B (including).

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your.

Input

The input file for this problem contains several test cases. First line of each case contains L (1 ≤ L ≤ 100000), T (1 ≤ T ≤ 30) and O (1 ≤ O ≤ 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1

 

呃,这真是一道好题……让我学会了lazy思想。(其实我在做这题超时的时候也萌生过这个想法,但是没有尝试,原来lazy思想只要很小改动即可)。另外就是位运算

 

本来应该如此:

每次paint:

把那个段和他的所有子段全都paint

然后把paint过的那些的颜色,返回给大的线段

 

每次查询:

如果前后对应了,就返回颜色,

如果还没对应好,就寻找子线段,并把两边子树的信息进行或操作。就是颜色的并集

 

但是这样的话每次都要递归很深。所以设一个lazy标记,表示他的子线段和他一样,都是同个颜色了。这样就需要在修改这个线段时把它再次标记去掉,并且把子树给标上

 

哎。今晚做这题做得太狗血了

#include <cstdio>
#include <algorithm>
using namespace std;
struct node{
	int l,r,cl;
	bool lz;
}t[300009];
void build(int st,int ed,int cr){
	t[cr].r=ed;
	t[cr].l=st;
	t[cr].cl=2;
	t[cr].lz=1;
	if(st==ed)
		return ;
	build(st,(st+ed)/2,2*cr);
	build((st+ed)/2+1,ed,cr*2+1);
	return ;
}
void insert(int st,int ed,int cr,int incl){
	if(t[cr].r==ed&&t[cr].l==st){
		t[cr].cl=(1<<incl);
		t[cr].lz=1;
		return ;//不用再递归了,这样子已经足够了
	}
	if(t[cr].lz){
		t[cr].lz=0;//插入的不是当前线段,而是子线段,那么把这个线段破开。并把这个点信息给子线段
		t[cr*2+1].cl=t[cr*2].cl=t[cr].cl;
		t[cr*2+1].lz=t[cr*2].lz=1;
	}
	int mid=(t[cr].r+t[cr].l)>>1;
	if(ed<=mid){
		insert(st,ed,2*cr,incl);
	}else if(st>mid){
		insert(st,ed,2*cr+1,incl);
	}else{
		insert(st,mid,2*cr,incl);
		insert(mid+1,ed,2*cr+1,incl);
	}
	t[cr].cl=t[cr*2].cl|t[cr*2+1].cl;
	return ;
}
int query(int st,int ed,int cr){
	if((t[cr].lz)||(t[cr].r==ed&&t[cr].l==st)){
		return t[cr].cl;
	}
	int mid=(t[cr].l+t[cr].r)>>1;
	if(ed<=mid){
		return query(st,ed,cr*2);
	}else if(st>mid){
		return query(st,ed,cr*2+1);
	}else{
		return query(st,mid,cr*2)|query(mid+1,ed,cr*2+1);
	}
}
int main(){
	int L,T,O,A,B,C,ret,ans;
	char op;
	while(scanf("%d%d%d",&L,&T,&O)==3){
		build(1,L,1);
		while(O--&&scanf(" %c",&op)){
			if(op=='C'){
				scanf("%d%d%d",&A,&B,&C);
				if(A>B)swap(A,B);
				insert(A,B,1,C);
			}else{
				scanf("%d%d",&A,&B);
				if(A>B)swap(A,B);
				ret=query(A,B,1);
				ans=0;
				for(int i=0;i<32;i++)
					if(ret&(1<<i))
						ans++;
				printf("%d\n",ans);
			}
		}
	}
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
东南亚位于我国倡导推进的“一带一路”海陆交汇地带,作为当今全球发展最为迅速的地区之一,近年来区域内生产总值实现了显著且稳定的增长。根据东盟主要经济体公布的最新数据,印度尼西亚2023年国内生产总值(GDP)增长5.05%;越南2023年经济增长5.05%;马来西亚2023年经济增速为3.7%;泰国2023年经济增长1.9%;新加坡2023年经济增长1.1%;柬埔寨2023年经济增速预计为5.6%。 东盟国家在“一带一路”沿线国家中的总体GDP经济规模、贸易总额与国外直接投资均为最大,因此有着举足轻重的地位和作用。当前,东盟与中国已互相成为双方最大的交易伙伴。中国-东盟贸易总额已从2013年的443亿元增长至 2023年合计超逾6.4万亿元,占中国外贸总值的15.4%。在过去20余年中,东盟国家不断在全球多变的格局里面临挑战并寻求机遇。2023东盟国家主要经济体受到国内消费、国外投资、货币政策、旅游业复苏、和大宗商品出口价企稳等方面的提振,经济显现出稳步增长态势和强韧性的潜能。 本调研报告旨在深度挖掘东南亚市场的增长潜力与发展机会,分析东南亚市场竞争态势、销售模式、客户偏好、整体市场营商环境,为国内企业出海开展业务提供客观参考意见。 本文核心内容: 市场空间:全球行业市场空间、东南亚市场发展空间。 竞争态势:全球份额,东南亚市场企业份额。 销售模式:东南亚市场销售模式、本地代理商 客户情况:东南亚本地客户及偏好分析 营商环境:东南亚营商环境分析 本文纳入的企业包括国外及印尼本土企业,以及相关上下游企业等,部分名单 QYResearch是全球知名的大型咨询公司,行业涵盖各高科技行业产业链细分市场,横跨如半导体产业链(半导体设备及零部件、半导体材料、集成电路、制造、封测、分立器件、传感器、光电器件)、光伏产业链(设备、硅料/硅片、电池片、组件、辅料支架、逆变器、电站终端)、新能源汽车产业链(动力电池及材料、电驱电控、汽车半导体/电子、整车、充电桩)、通信产业链(通信系统设备、终端设备、电子元器件、射频前端、光模块、4G/5G/6G、宽带、IoT、数字经济、AI)、先进材料产业链(金属材料、高分子材料、陶瓷材料、纳米材料等)、机械制造产业链(数控机床、工程机械、电气机械、3C自动化、工业机器人、激光、工控、无人机)、食品药品、医疗器械、农业等。邮箱:market@qyresearch.com

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值