POJ 1270 HOJ 1170 Following Orders

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 3057 Accepted: 1171

Description

Order is an important concept in mathematics and in computer science. For example, Zorn's Lemma states: ``a partially ordered set in which every chain has an upper bound contains a maximal element.'' Order is also important in reasoning about the fix-point semantics of programs.


This problem involves neither Zorn's Lemma nor fix-point semantics, but does involve order.
Given a list of variable constraints of the form x < y, you are to write a program that prints all orderings of the variables that are consistent with the constraints.


For example, given the constraints x < y and x < z there are two orderings of the variables x, y, and z that are consistent with these constraints: x y z and x z y.

Input

The input consists of a sequence of constraint specifications. A specification consists of two lines: a list of variables on one line followed by a list of contraints on the next line. A constraint is given by a pair of variables, where x y indicates that x < y.


All variables are single character, lower-case letters. There will be at least two variables, and no more than 20 variables in a specification. There will be at least one constraint, and no more than 50 constraints in a specification. There will be at least one, and no more than 300 orderings consistent with the contraints in a specification.


Input is terminated by end-of-file.

Output

For each constraint specification, all orderings consistent with the constraints should be printed. Orderings are printed in lexicographical (alphabetical) order, one per line.


Output for different constraint specifications is separated by a blank line.

Sample Input

a b f g
a b b f
v w x y z
v y x v z v w v

Sample Output

abfg
abgf
agbf
gabf

wxzvy
wzxvy
xwzvy
xzwvy
zwxvy
zxwvy

 

 

 

 

 

蒽,综合了DFS和拓扑排序,可以这么想:

 

先建一个图,由于是这种严格偏序关系,想到拓扑排序。

 

我是这么理解拓扑的:

拓扑排序只有一种排法,如果所有的元素都规定好了关系。比如如果有四个元素,规定好a<b,b<c,c<d,这个排序就唯一了

但当他们没有完全规定好关系的时候。有多个拓扑子图。然后每步选择哪个子图,都随便。

 

对子拓扑图的选择,就是DFS的转移方法数

 

比如第一例,

GIVEN :A B F G

 

图1:

A<B,B<F

图2:

G

 

所以第一次可以选G,也可以选A

第一次如果选A,第二次可以选G、B

如此如此

#include <cstdio>
#include <cstring>
#include <algorithm>
#define rep(i,a,b) for(int i=a;i<b;i++)
#define INIT(a,b) memset(a,b,sizeof(a))
typedef long long ll;
using namespace std;
char buf[1000],u,v,ch[30];
bool g[30][30];
int n,mp[260],uu,vv,in[30],pt[30];
void dfs(int lv){
	if(lv==n){
		rep(i,0,n)	putchar(ch[pt[i]]);
		putchar('\n');
		return ;
	}
	rep(i,0,n)
	if(!in[i]){
		pt[lv]=i;
		in[i]--;
		rep(j,0,n)if(g[i][j])
			in[j]--;
		dfs(lv+1);
		rep(j,0,n)if(g[i][j])
			in[j]++;
		in[i]++;

	}
}
int main(){
	int cas=0;
	while(gets(buf)){
		INIT(in,0);
		n=0;
		int pt=0,pt_1;
		while(u=buf[pt++]){
			if(u==' ')continue;
			ch[n++]=u;
		}
		sort(ch,ch+n);
		rep(i,0,n)	mp[ch[i]]=i;
		INIT(g,0);
		gets(buf);
		pt_1=pt=0;
		while(v=buf[pt++]){
			if(v==' ')	continue;
			pt_1=!pt_1;
			if(pt_1)	u=v;
			else	g[mp[u]][mp[v]]=1;
		}
		rep(i,0,n)rep(j,0,n)
		rep(k,0,n)if(g[i][j]&&g[j][k])
			g[i][k]=1;
		if(cas++)	putchar('\n');
		rep(i,0,n)rep(j,0,n)if(g[j][i])
			in[i]++;
		dfs(0);
	}
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
东南亚位于我国倡导推进的“一带一路”海陆交汇地带,作为当今全球发展最为迅速的地区之一,近年来区域内生产总值实现了显著且稳定的增长。根据东盟主要经济体公布的最新数据,印度尼西亚2023年国内生产总值(GDP)增长5.05%;越南2023年经济增长5.05%;马来西亚2023年经济增速为3.7%;泰国2023年经济增长1.9%;新加坡2023年经济增长1.1%;柬埔寨2023年经济增速预计为5.6%。 东盟国家在“一带一路”沿线国家中的总体GDP经济规模、贸易总额与国外直接投资均为最大,因此有着举足轻重的地位和作用。当前,东盟与中国已互相成为双方最大的交易伙伴。中国-东盟贸易总额已从2013年的443亿元增长至 2023年合计超逾6.4万亿元,占中国外贸总值的15.4%。在过去20余年中,东盟国家不断在全球多变的格局里面临挑战并寻求机遇。2023东盟国家主要经济体受到国内消费、国外投资、货币政策、旅游业复苏、和大宗商品出口价企稳等方面的提振,经济显现出稳步增长态势和强韧性的潜能。 本调研报告旨在深度挖掘东南亚市场的增长潜力与发展机会,分析东南亚市场竞争态势、销售模式、客户偏好、整体市场营商环境,为国内企业出海开展业务提供客观参考意见。 本文核心内容: 市场空间:全球行业市场空间、东南亚市场发展空间。 竞争态势:全球份额,东南亚市场企业份额。 销售模式:东南亚市场销售模式、本地代理商 客户情况:东南亚本地客户及偏好分析 营商环境:东南亚营商环境分析 本文纳入的企业包括国外及印尼本土企业,以及相关上下游企业等,部分名单 QYResearch是全球知名的大型咨询公司,行业涵盖各高科技行业产业链细分市场,横跨如半导体产业链(半导体设备及零部件、半导体材料、集成电路、制造、封测、分立器件、传感器、光电器件)、光伏产业链(设备、硅料/硅片、电池片、组件、辅料支架、逆变器、电站终端)、新能源汽车产业链(动力电池及材料、电驱电控、汽车半导体/电子、整车、充电桩)、通信产业链(通信系统设备、终端设备、电子元器件、射频前端、光模块、4G/5G/6G、宽带、IoT、数字经济、AI)、先进材料产业链(金属材料、高分子材料、陶瓷材料、纳米材料等)、机械制造产业链(数控机床、工程机械、电气机械、3C自动化、工业机器人、激光、工控、无人机)、食品药品、医疗器械、农业等。邮箱:market@qyresearch.com

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值