HOJ 2368 A DP Problem


 Source : Tehran 2003
 Time limit : 1 sec Memory limit : 64 M

Submitted : 98, Accepted : 43

In this problem, you are to solve a very easy linear equation with only one variable x with no parentheses! An example of such equations is like the following:

2x - 4 + 5x + 300 = 98x

An expression in its general form, will contain a '=' character with two expressions on its sides. Each expression is made up of one or more terms combined by '+' or '-' operators. No unary plus or minus operators are allowed in the expressions. Each term is either a single integer, or an integer followed by the lower-case character x or the single character x which is equivalent to 1x.

You are to write a program to find the value of x that satisfies the equation. Note that it is possible for the equation to have no solution or have infinitely many. Your program must detect these cases too.

Input

The first number in the input line, t (1 <= t <= 10) is the number of test cases, followed by t lines of length at most 260 each containing an equation. There is no blank character in the equations and the variable is always represented by the lower-case character x. The coefficients are integers in the range (0...1000) inclusive.

Output

The output contains one line per test case containing the solution of the equation. If s is the solution to the equation, the output line should contain [s] (the floor of s, i.e., the largest integer number less than or equal to s). The output should be IMPOSSIBLE or IDENTITY if the equation has no solution or has infinite solutions, respectively. Note that the output is case-sensitive.

Sample Input

2 
2x-4+5x+300=98x
x+2=2+x

Sample Output

3
IDENTITY








我是因为看到DP才做的。后来发现……

这个,其实就是模拟。但是模拟的水平有不同,像我的代码就特别不好。


然后记得floor是绝对值的取下限,所以-3.3会变成-3.但是题目要求他应该是-4才对。所以自己特殊处理下

由于是模拟,加上我的代码很差,这个就给我自己留下参考了……

#include <cstdio>
#include <cstring>
#include <cmath>
#define rep(i,a,b) for(int i=a;i<b;i++)
#define erep(i,a,b) for(int i=a;i<=b;i++)
int t,len,eq,nm[2],xx[2];
char s[1009];
void op(int st,int ed,int fl){
	int pn;
	rep(i,st,ed){
		pn=1;
		if(s[i]=='-')	pn=-1,i++;
		else if(s[i]=='+')	i++;
		if(s[i]=='x')	xx[fl]+=pn;
		else{
			int tmp=0;
			erep(j,i,ed+1){
				if(s[j]=='x'){
					xx[fl]+=tmp*pn;
					i=j;
					break;
				}else if(s[j]=='+'||s[j]=='-'||s[j]=='='){
					nm[fl]+=tmp*pn;
					i=j-1;
					break;
				}
				tmp=tmp*10+s[j]-'0';
			}
		}
	}
}
int main(){
	int t;
	scanf("%d",&t);
	while(t--&&scanf("%s",s)){
		nm[0]=nm[1]=xx[0]=xx[1]=0;
		len=strlen(s);
		rep(i,0,len)
		if(s[i]=='=')
			eq=i;
		s[len]='=';
		op(0,eq,0);
		op(eq+1,len,1);
		if(xx[0]==xx[1]&&nm[0]==nm[1])puts("IDENTITY");
		else if(xx[0]==xx[1]&&nm[0]!=nm[1])puts("IMPOSSIBLE");
		else{
			if((nm[1]-nm[0])/(xx[0]-xx[1])>=0||(nm[1]-nm[0])%(xx[0]-xx[1])==0)printf("%d\n",(int)(floor(nm[1]-nm[0])/(xx[0]-xx[1])));
			else	printf("%d\n",(int)(floor((nm[1]-nm[0])/(xx[0]-xx[1]))-1));
		}
	}
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
东南亚位于我国倡导推进的“一带一路”海陆交汇地带,作为当今全球发展最为迅速的地区之一,近年来区域内生产总值实现了显著且稳定的增长。根据东盟主要经济体公布的最新数据,印度尼西亚2023年国内生产总值(GDP)增长5.05%;越南2023年经济增长5.05%;马来西亚2023年经济增速为3.7%;泰国2023年经济增长1.9%;新加坡2023年经济增长1.1%;柬埔寨2023年经济增速预计为5.6%。 东盟国家在“一带一路”沿线国家中的总体GDP经济规模、贸易总额与国外直接投资均为最大,因此有着举足轻重的地位和作用。当前,东盟与中国已互相成为双方最大的交易伙伴。中国-东盟贸易总额已从2013年的443亿元增长至 2023年合计超逾6.4万亿元,占中国外贸总值的15.4%。在过去20余年中,东盟国家不断在全球多变的格局里面临挑战并寻求机遇。2023东盟国家主要经济体受到国内消费、国外投资、货币政策、旅游业复苏、和大宗商品出口价企稳等方面的提振,经济显现出稳步增长态势和强韧性的潜能。 本调研报告旨在深度挖掘东南亚市场的增长潜力与发展机会,分析东南亚市场竞争态势、销售模式、客户偏好、整体市场营商环境,为国内企业出海开展业务提供客观参考意见。 本文核心内容: 市场空间:全球行业市场空间、东南亚市场发展空间。 竞争态势:全球份额,东南亚市场企业份额。 销售模式:东南亚市场销售模式、本地代理商 客户情况:东南亚本地客户及偏好分析 营商环境:东南亚营商环境分析 本文纳入的企业包括国外及印尼本土企业,以及相关上下游企业等,部分名单 QYResearch是全球知名的大型咨询公司,行业涵盖各高科技行业产业链细分市场,横跨如半导体产业链(半导体设备及零部件、半导体材料、集成电路、制造、封测、分立器件、传感器、光电器件)、光伏产业链(设备、硅料/硅片、电池片、组件、辅料支架、逆变器、电站终端)、新能源汽车产业链(动力电池及材料、电驱电控、汽车半导体/电子、整车、充电桩)、通信产业链(通信系统设备、终端设备、电子元器件、射频前端、光模块、4G/5G/6G、宽带、IoT、数字经济、AI)、先进材料产业链(金属材料、高分子材料、陶瓷材料、纳米材料等)、机械制造产业链(数控机床、工程机械、电气机械、3C自动化、工业机器人、激光、工控、无人机)、食品药品、医疗器械、农业等。邮箱:market@qyresearch.com

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值