UVA 10881 - Piotr's Ants

题目:

Problem D
Piotr's Ants
Time Limit: 2 seconds

"One thing is for certain: there is no stopping them;
the ants will soon be here. And I, for one, welcome our
new insect overlords."

Kent Brockman

Piotr likes playing with ants. He has n of them on a horizontal pole L cm long. Each ant is facing either left or right and walks at a constant speed of 1 cm/s. When two ants bump into each other, they both turn around (instantaneously) and start walking in opposite directions. Piotr knows where each of the ants starts and which direction it is facing and wants to calculate where the ants will end up T seconds from now.

Input
The first line of input gives the number of cases, NN test cases follow. Each one starts with a line containing 3 integers: L , T and n  (0 <=  n <= 10000) . The next n lines give the locations of the n ants (measured in cm from the left end of the pole) and the direction they are facing (L or R).

Output
For each test case, output one line containing "Case #x:" followed by n lines describing the locations and directions of the n ants in the same format and order as in the input. If two or more ants are at the same location, print "Turning" instead of "L" or "R" for their direction. If an ant falls off the pole before Tseconds, print "Fell off" for that ant. Print an empty line after each test case.

Sample InputSample Output
2
10 1 4
1 R
5 R
3 L
10 R
10 2 3
4 R
5 L
8 R
Case #1:
2 Turning
6 R
2 Turning
Fell off

Case #2:
3 L
6 R
10 R

传送门: 点击打开链接


解题思路:

对于蚂蚁整体来说,我们可以认为蚂蚁相遇之后不回头,继续往原方向前进,这样看是忽略了蚂蚁个体间的差异。对于这道题目,我们不能忽略蚂蚁的个体差异,不过,仔细想一想,我们可以发现,其实,蚂蚁的相对顺序是不变的,我们可以把开始和结束时,蚂蚁的位置按从小到大排序,这样,在一个位置上,他们对应的就是同一只蚂蚁,我们需要另外一个数组order来保存他们之间的位置对应关系。


代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int MAXN = 1e5+10;
struct ANT
{
    int id, pos, dir;
};
ANT before[MAXN], after[MAXN];
int order[MAXN];

bool cmp(const ANT &a, const ANT &b)
{
    return a.pos < b.pos;
}

int main()
{
    int icase, l, t, n, w = 1;
    scanf("%d", &icase);
    while(icase--)
    {
        scanf("%d%d%d", &l, &t, &n);
        for(int i = 0; i < n; ++i)
        {
            int p, d; char c;
            scanf("%d %c", &p, &c);
            d = ('L'==c ? -1 : 1);
            before[i] = (ANT){i, p, d};
            after[i]  = (ANT){0, p+t*d, d};
        }

        sort(before, before+n, cmp);
        for(int i = 0; i < n; ++i)
            order[before[i].id] = i;
        sort(after, after+n, cmp);
        for(int i = 0; i < n-1; ++i)
        {
            if(after[i].pos == after[i+1].pos)
                after[i].dir = after[i+1].dir = 0;
        }

        printf("Case #%d:\n", w++);
        for(int i = 0; i < n; ++i)
        {
            if(after[order[i]].pos>l ||
               after[order[i]].pos<0)
               printf("Fell off\n");
            else if(0 == after[order[i]].dir)
                printf("%d Turning\n", after[order[i]].pos);
            else if(1 == after[order[i]].dir)
                printf("%d R\n", after[order[i]].pos);
            else printf("%d L\n", after[order[i]].pos);
        }
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值