poj 1163 The Triangle

The Triangle
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 33657 Accepted: 19980

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

Source

求 从三角形顶部到底部整个过程中最大的。

动归题目,可以从倒数第二层开始,选择它底下那一层并且和它相邻的两个数中间比较大的那一个。然后与现在的数字求和。

最后输出顶端的数据就行。

#include<iostream>
#include<string>
using namespace std;
int max(int a,int b)
{
	return a>b?a:b;
}
int map[2000][2000];
int main()
{
	int n;
	int i,j;
	while(~scanf("%d",&n))
	{
		for(i=0;i<n;i++)
		{
			for(j=0;j<=i;j++)
			{
				scanf("%d",&map[i][j]);
			}
		}
		for(i=n-2;i>=0;i--)
		{
			for(j=i;j>=0;j--)
			{
				map[i][j]+=max(map[i+1][j],map[i+1][j+1]);
			}
		}
		cout<<map[0][0]<<endl;

	}
return 0;
}




                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值