Square_hdu_1518(深搜)

Square

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5868    Accepted Submission(s): 1869


Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 

Sample Input
  
  
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

Sample Output
  
  
yes no yes
 

Source
 


import java.util.Arrays;
import java.util.Comparator;
import java.util.Scanner;

public class Main{//8855163	2013-08-07 11:15:44	Accepted	1518	968MS	3940K	1278 B	Java	zhangyi
	private static boolean vis[],ok=true;
	private static Integer a[],sum=0,n;
	public static void main(String[] args) {
		Scanner input=new Scanner(System.in);
		int N=input.nextInt();
		while(N-->0){
			n=input.nextInt();
			Init();
			int max=0;
			for(int i=0;i<n;++i){
				a[i]=input.nextInt();
				max+=a[i];
			}
			sum=max>>2;
			Arrays.sort(a,new Comparator<Integer>(){    //从大到小排序
                @Override
                public int compare(Integer o1, Integer o2){
                    return o2-o1;
                }
            });
			if(max%4==0&&sum>=a[0]){
				dfs(0,0,0);//当时少了一个参数,导致超时
				if(ok)
					System.out.println("yes");
				else
					System.out.println("no");
			}
			else{
				System.out.println("no");
			}
		}
	}
	private static void Init() {
		sum=0;
		ok=false;
		a=new Integer[n];
		vis=new boolean[n];
	}
	private static void dfs(int s, int num,int i) {//一定要加i,否则会超时,下次直接从i处搜
		if(ok)
			return;
		if(num==3){
			ok=true;
			return;
		}
		if(s==sum){
			dfs(0,num+1,num+1);
		}
		for(;i<n;i++){
			if(!vis[i]){
				if(s+a[i]<=sum){
					vis[i]=true;
						dfs(s+a[i],num,i+1);
					vis[i]=false;
				}
			}
		}
	}
}



import java.util.Arrays;
import java.util.Comparator;
import java.util.Scanner;

public class Main{//1508MS
	static boolean vis[];
	static Integer a[],arge=0;
	public static void main(String[] args) {
		Scanner input=new Scanner(System.in);
		int N=input.nextInt();
		while(N-->0){
			int n=input.nextInt();
			a=new Integer[n];
			vis=new boolean[n];
			int sum=0;
			for(int i=0;i<n;i++){
				a[i]=input.nextInt();
				sum+=a[i];
			}
			arge=sum>>2;
			if(sum%4==0){
				Arrays.sort(a,new Comparator<Integer>(){

					@Override
					public int compare(Integer o1, Integer o2) {
						return o2-o1;
					}
					
				});
				if(arge>=a[0]&&dfs(0,0,0)){
					System.out.println("yes");
				}
				else
					System.out.println("no");
			}
			else{
				System.out.println("no");
			}
		}
	}
	private static boolean dfs(int len, int num, int i) {
		if(num==3)
			return true;
		if(len==arge){
			if(dfs(0,num+1,num+1))
				return true;
			else
				return false;
		}
		else{
			for(;i<a.length;i++){
				if(!vis[i]){
					if(len+a[i]<=arge){
						vis[i]=true;
						if(dfs(len+a[i],num,i+1)){
							return true;
						}
						vis[i]=false;
					}
				}
			}
		}
		return false;
	}
}


好的,关于 HDU4992 求所有原根的问题,我可以给出以下解答: 1. 首先,我们需要知道什么是原根。原根是指模 n 意义下,所有与 n 互质的数 a 的最小正整数 k 次幂对 n 取模的值覆盖了所有与 n 互质的数。简单来说,就是如果一个数 a 是模 n 意义下的原根,那么 a 的任何正整数次幂对 n 取模的值都不相同,且能覆盖所有与 n 互质的数。 2. 为了求模 n 意义下的所有原根,我们需要先求出与 n 互质的数的个数 phi(n)。phi(n) 可以使用欧拉函数求出。 3. 然后,我们需要枚举模 n 意义下的所有数,判断它是否是原根。具体来说,对于每个 a,我们需要判断 a 的每个小于 phi(n) 的正整数次幂对 n 取模的值是否都不相同,且能覆盖所有与 n 互质的数。如果是,那么 a 就是模 n 意义下的原根。 4. 代码实现可以参考以下 Java 代码: ``` import java.util.*; public class Main { static int gcd(int a, int b) { return b == 0 ? a : gcd(b, a % b); } static int phi(int n) { int res = n; for (int i = 2; i * i <= n; i++) { if (n % i == 0) { res = res / i * (i - 1); while (n % i == 0) { n /= i; } } } if (n > 1) { res = res / n * (n - 1); } return res; } static int pow(int a, int b, int mod) { int res = 1; while (b > 0) { if ((b & 1) != 0) { res = res * a % mod; } a = a * a % mod; b >>= 1; } return res; } static boolean check(int a, int n, int phi) { for (int i = 1, j = pow(a, i, n); i <= phi; i++, j = j * a % n) { if (j == 1) { return false; } } return true; } public static void main(String[] args) { Scanner scanner = new Scanner(System.in); while (scanner.hasNext()) { int n = scanner.nextInt(); int phi = phi(n); List<Integer> ans = new ArrayList<>(); for (int i = 1; i < n; i++) { if (gcd(i, n) == 1 && check(i, n, phi)) { ans.add(i); } } Collections.sort(ans); for (int x : ans) { System.out.print(x + " "); } System.out.println(); } } } ``` 其中,gcd 函数用于求最大公约数,phi 函数用于求欧拉函数,pow 函数用于快速幂求模,check 函数用于判断一个数是否是原根。在主函数中,我们依次读入每个 n,求出 phi(n),然后枚举模 n 意义下的所有数,判断它是否是原根,将所有原根存入一个 List 中,最后排序输出即可。 希望我的回答能够帮到你,如果你有任何问题,欢迎随时提出。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值