hdu 1518 Square

Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 

Sample Input
  
  
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

Sample Output
  
  
yes no yes

给出M根棍子,要将所有棍子用上,拼成一个正方形。

#include<iostream>
#include<stdio.h>
#include <string.h>
#include <algorithm>
using  namespace std;
int s[25],m,a,sum;
bool vis[25];
bool dfs(int cnt,int now,int k)
{
    if(cnt==5)
    {
        return true;
    }
    for (int i=k; i<m; i++)
    {
        if(!vis[i])
        {
            if(now+s[i]<a)
            {
                vis[i]=true;
                if(dfs(cnt,now+s[i],i+1))
                {
                    return true;
                }
                vis[i]=false;
            }
            if(now+s[i]==a)
            {
                vis[i]=true;
                if(dfs(cnt+1,0,0))
                {
                    return true;
                }
                vis[i]=false;
            }
        }
    }
    return false;
}
int main()
{
    int t,i;
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d",&m);
        sum=0;
        memset(vis, false, sizeof(vis));
        for (i=0; i<m; i++)
        {
            scanf("%d",&s[i]);
            sum+=s[i];
        }
        if(sum%4!=0)
        {
            printf("no\n");
            continue;
        }
        a=sum/4;
        sort(s, s+m, greater<int>());
        if(s[0]>a)
        {
            printf("no\n");
            continue;
        }
        if(dfs(1,0,0))
        {
            printf("yes\n");
        }
        else
        {
            printf("no\n");
        }
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值