ZOJ Problem Set - 1095 丑数

提交地址http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1095

Humble Numbers

Time Limit: 2 Seconds      Memory Limit: 65536 KB

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence.

Input Specification

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output Specification

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.
这个题目拿到的时候我以为只要被2,3,5,7中的一个整除就行了,但是我发现错了。。。

我从书上看到这是一种打点的方法。我更觉得只是一种解题的方法。

#include<stdio.h>
using namespace std;
#define min(a,b) ((a)<(b)?(a):(b))
#define min4(a,b,c,d) min(min(a,b),min(c,d))
int a[5843];
int main()
{
	int index=1;
	int p2=1,p3=1,p5=1,p7=1;
	a[1]=1;
	while(index<5843)
	{
		a[++index]=min4(2*a[p2],3*a[p3],5*a[p5],7*a[p7]);
		{
			if(a[index]==a[p2]*2) p2++;
			if(a[index]==a[p3]*3) p3++;
			if(a[index]==a[p5]*5) p5++;
			if(a[index]==a[p7]*7) p7++;
		}
	}
	int  n;
	while(scanf("%d",&n)==1&&n!=0)
	{
		printf("The %d",n);
		int ten  = n/10%10;
		if(n%10==1&&ten!=1)printf("st");
		else if(n%10==2&&ten!=1)printf("nd");
		else if(n%10==3 &&ten!=1)printf("rd");
		else printf("th");
		printf(" humble number is %d.\n",a[n]);

	}
}
像while循环里面那样 由当前有的这些元素逐渐推下一个元素。一直推到第想要的个数后退出。

是个输出我感觉很烦。好了!

感谢自己坚持!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值