hdu 3068最长回文子串

最长回文

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3759    Accepted Submission(s): 1261


Problem Description
给出一个只由小写英文字符a,b,c...y,z组成的字符串S,求S中最长回文串的长度.
回文就是正反读都是一样的字符串,如aba, abba等
 

 

Input
输入有多组case,不超过120组,每组输入为一行小写英文字符a,b,c...y,z组成的字符串S
两组case之间由空行隔开(该空行不用处理)
字符串长度len <= 110000
 

 

Output
每一行一个整数x,对应一组case,表示该组case的字符串中所包含的最长回文长度.
 

 

Sample Input
aaaa abab
 

 

Sample Output
4 3

Manacher算法求最长回文子串时间复杂度O(n),比后缀数组低很多。

#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
#include <math.h>
using namespace std;

int Proc(char pszIn[],char pszOut[])
{
    int nLen=1;
    pszOut[0]='$';
    int i=0;
    while(pszIn[i]!='\0')
    {
        pszOut[nLen++]='#';
        pszOut[nLen++]=pszIn[i];
        i++;
    }
    pszOut[nLen++]='#';
    pszOut[nLen]=0;
    return nLen;
}
void Manacher(int *p,char *str,int len)
{
    int mx=0,id=0;
    for(int i=0;i<len;i++)
    {
        p[i]=mx>i?min(p[2*id-i],mx-i):1;
        while(str[i+p[i]]==str[i-p[i]])p[i]++;
        if(i+p[i]>mx)
        {
            mx=i+p[i];
            id=i;
        }
    }
}
const int MAXN=220010;
char strIn[MAXN];
char strOut[MAXN];
int p[MAXN];
int main()
{
    while(scanf("%s",strIn)!=EOF)
    {
        int nLen=Proc(strIn,strOut);
        Manacher(p,strOut,nLen);
        int ans=1;
        for(int i=0;i<nLen;i++)
            ans=max(ans,p[i]);
        printf("%d\n",ans-1);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值