hdu 1054 Strategic Game(最小点覆盖集转换成双向二分图)

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree: 

 

the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:
 

Sample Input
  
  
4 0:(1) 1 1:(2) 2 3 2:(0) 3:(0) 5 3:(3) 1 4 2 1:(1) 0 2:(0) 0:(0) 4:(0)
 

Sample Output
  
  
1 2
 

题意 : 给你一个图,求最小点覆盖集 :
         最小点覆盖集=最大匹配  ,  扩展到双向的;  ( 单向貌似也行)
          因此,公式转换成 :   最小点覆盖集=二分图最大匹配(双向)/2  ;
  数据太大,要用邻接表存储 :

#include<cstdio>
#include<cstring>
//#include<map>
#include<vector>
#include<cmath>
#include<cstdlib>
#include<stack>
#include<queue>
#include<iostream>
#include<algorithm>
using namespace std ;
#define N 1600 
bool flag[N];
int match[N];
vector<int>map[N];  // 用存储


int dfs(int x)
{
for( int i = 0 ; i < map[x].size() ; i++)        //和x点有连线的点的数量为 map[x].size()  ;
{
int  v = map[x][i] ;
if(!flag[v])
{
 flag[v] = true ;   //访问过此点,标记 :
if(match[v]==-1 || dfs( match[v]))
{
  match[v]=x;
  return 1;
}
}

}
return 0;
}


int main()
{
int i,j,r,k,sum,num,n ;
while(~scanf("%d",&n))
{
for( i = 0 ; i < n ; i++)  map[i].clear() ;
for(  i = 0 ; i < n ; i++)
{
 scanf("%d:(%d)",&k,&sum);
 for(j = 0 ; j < sum ; j++)
 {
   scanf("%d",&r);
   map[k].push_back(r);  //邻接表
   map[r].push_back(k);  //建双向图
 }
}
num = 0 ; 
memset(match,-1,sizeof(match));
for( i = 0 ;  i < n ; i++)
{
   memset(flag,false,sizeof(flag));
     num += dfs( i ) ; 
}
printf("%d\n",num/2);
}
return 0 ;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值