HDOJ_1001 Sum Problem

Problem Description

Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1+ 2 + ... + n

 

Input

The input will consist of a series of integers n,one integer per line.

[consist] verb 存在 consist of 由什么组成

[Series of] 一系列,连续

 

Output

For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will 

be in the range of 32_bit signed integer.

[follow by] A is followed by B. AB跟随

 

Sample Input

1

100

 

Sample Output

1

 

5050

 

 

问题描述

嘿,欢迎来到HDOJ(杭州电子大学OJ

在这个问题中,你的任务是计算SUM(n) = 1 + 2 ... + n

 

输入

输入将由一系列整数n组成,一个整数一行

 

输出

对于每个实例,在一行中输出SUM(n),跟在一个空行之后。你可能要假设结果在32位整数范围之内。

 

输入样例

1

100

 

输出样例

1

 

5050

 

C++通过版:

#include<iostream>
using namespace std;

int main( void )
{
	
	int n;
	int sum = 0;
	
	
	while( cin >> n )
	{
		
		
		for( int j = 1; j <= n; j++ )
		{
			sum += j;
		}
		
		cout << sum << endl << endl;
		sum = 0;
	}
	return 0;
}



 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值