[并查集]HDU 1829/POJ 2492/HOJ 2319 A Bug's Life

传送门:A Bug's Life

A Bug's Life

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6961    Accepted Submission(s): 2267


Problem Description
Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

Sample Input
  
  
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
  
  
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint
Huge input,scanf is recommended.
 

Source

解题报告:

这个题属于并查集中求偏移量的问题,给你的2个人的关系,已知他们是异性,要求你判断其中是否可能存在同性恋。

代码如下:

#include<iostream>
#include<cstdio>
using namespace std;
int m,n,flag;
int father[20005],r[20005];
void makeset(int n){
    for(int j=1;j<=n;j++){
        father[j]=j;
        r[j]=0;
    }
}
int findset(int x){
    int a=father[x];
    if(father[x]==x)
        return x;
    father[x]=findset(father[x]);
    r[x]=(r[x]+r[a])%2;
    return father[x];
}
void Union(int a,int b){
    if(flag)
        return;
    int x=findset(a);
    int y=findset(b);
    if(x==y&&r[a]==r[b]){
        flag=1;
        return;
    }
    father[x]=y;
    r[x]=(r[a]+r[b]+1)%2;
}
int main(){
    int t,s=0;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        flag=0;
        makeset(n);
        for(int i=0;i<m;i++){
            int a,b;
            scanf("%d%d",&a,&b);
            Union(a,b);
        }
        printf("Scenario #%d:\n",++s);
        flag?puts("Suspicious bugs found!\n"):puts("No suspicious bugs found!\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值