ZOJ3475解题报告

Edward has established a company with n staffs. He is such a kind man that he did Q times salary increasing for his staffs. Each salary increasing was described by three integers (l, r, c). That means Edward will add c units money for the staff whose salaxy is in range [l, r] now. Edward wants to know the amount of total money he should pay to staffs after Q times salary increasing.

Input

The input file contains multiple test cases.

Each case begin with two integers : n -- which indicate the amount of staff; Q -- which indicate Q times salary increasing. The following n integers each describes the initial salary of a staff(mark as ai). After that, there are Q triples of integers (li, ri, ci) (i=1..Q) which describe the salary increasing in chronological.

1 ≤ n ≤ 105 , 1 ≤ Q ≤ 105 , 1 ≤ ai ≤ 105 , 1 ≤ liri ≤ 105 , 1 ≤ ci ≤ 105 , ri < li+1

Process to the End Of File.

Output

Output the total salary in a line for each case.

Sample Input
4 1
1 2 3 4
2 3 4
Sample Output
18
Hint

{1, 2, 3, 4} → {1, 4, 6, 7}. 

/* 题目:Salary Increasing
   链接 : //http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3745
   题意:在数组的指定范围的数值的元素上增加的一个值,求最后的数组总值
   思路:暴力。先求初始时总值,并且记录每个值的个数,增加值时,在原来的和的基础上增加相应的值,最后就得出总值了
*/
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
#define LL long long
#define M 100050
LL a[M],l,r,n,c,q,ctotal[M],temp[M],ans;
int main()
{
    LL i,j;
    while(~scanf("%lld %lld",&n,&q))
    {
        ans=0;
        memset(ctotal,0,sizeof(ctotal));
        memset(temp,0,sizeof(temp));
        for(i=1;i<=n;i++)
            {
                scanf("%lld",&a[i]);
                temp[a[i]]++;
                ans+=a[i];
            }
             memcpy(ctotal,temp,sizeof(temp));
        while(q--)
        {
            scanf("%lld %lld %lld",&l,&r,&c);

            for(i=l;i<=r;i++)
            {
                if(i+c<M)
                ctotal[i+c]=temp[i]+temp[c+i];
                ans+=temp[i]*c;
                temp[i]=0;
            }
            for(i=l;i<l+c&&i<M;i++) ctotal[i]=0;
            for(i=l+c;i<=r+c&&i<M;i++) temp[i]=ctotal[i];
        }
        printf("%lld\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值