zoj 1610 解题报告

Count the Colors


Time Limit: 2 Seconds      Memory Limit: 65536 KB


Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can see at last.


Input

The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.


Output

Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

If some color can't be seen, you shouldn't print it.

Print a blank line after every dataset.


Sample Input

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1


Sample Output

1 1
2 1
3 1

1 1

0 2
1 1


这题注意的是对于修改区间【1,2】改为颜色3

|——|——|——|——|——|

0      1       2     3      4       5

以这个为例,其实修改的是点‘1’和点‘2’之间的这段,点‘1’和点‘2’是不被染色

对于下面这个操作

3

1 2 c1

2 3 c2

3 4 c3

最后的颜色应该是这样的

|————|————|————|                                           ____________>这三段颜色

1 ~c1~    2  ~ c2~  3  ~c3~   4                                                                  

而不是两段颜色

我们对于修改区间a,b的颜色,更新时可以稍微处理就是变成区间【a+1,b】这段

也就是代码部分里的这部分

那么上面那个案例最后的颜色是:(以线段树的每个节点表示某个区间,如节点1表示的原先点‘1’点‘2’之间的一段)

套用下模板:

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <map>

using namespace std;

const int maxn=8005;
int n,last;
int col[maxn<<2],ans[maxn];
void pushdown(int root)
{
    if(col[root]!=-1) //父节点有颜色,就将其颜色传给左右儿子
    {
        col[root<<1]=col[root<<1|1]=col[root];
        col[root]=-1;
    }
}
void update(int ll,int rr,int l,int r,int root,int c)
{
    if(ll<=l&&r<=rr)
    {
        col[root]=c;
        return ;
    }
    if(col[root]==c) return ;//说明该节点颜色是c就不用修改了
    pushdown(root);
    int mid=l+r>>1;
    if(ll<=mid) update(ll,rr,l,mid,root<<1,c);
    if(rr>mid) update(ll,rr,mid+1,r,root<<1|1,c);
}
void query(int l,int r,int root)
{
    if(l==r)
    {  //这里的last很巧妙,为甚么我就没想到了
        //last表示的root-1的颜色,如果last与root的颜色不同说明是root表示的是一个新的颜色区间的头,然后将last更新为root的颜色
        if(col[root]!=-1&&col[root]!=last)
        {
            ans[col[root]]++;
        }
        last=col[root];
        return ;
    }
    pushdown(root);
    if(l==r) return ;
    int mid=l+r>>1;
    query(l,mid,root<<1);
    query(mid+1,r,root<<1|1);
}
int main()
{
    while(~scanf("%d",&n))
    {
        memset(col,-1,sizeof(col));
        for(int i =0;i<n;i++)
        {
            int x,y,c;
            scanf("%d%d%d",&x,&y,&c);
            update(x+1,y,1,8000,1,c);
        }
        memset(ans,0,sizeof(ans));
        last=-1;
        query(1,8000,1);
        for(int i=0;i<=8000;i++)
            if(ans[i]) printf("%d %d\n",i,ans[i]);
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值