hdu 4323 Magic Number (最短编辑距离)

Magic Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1404    Accepted Submission(s): 589


Problem Description
There are many magic numbers whose lengths are less than 10. Given some queries, each contains a single number, if the Levenshtein distance (see below) between the number in the query and a magic number is no more than a threshold, we call the magic number is the lucky number for that query. Could you find out how many luck numbers are there for each query?

Levenshtein distance (from Wikipedia http://en.wikipedia.org/wiki/Levenshtein_distance):
In information theory and computer science, the Levenshtein distance is a string metric for measuring the amount of difference between two sequences. The term edit distance is often used to refer specifically to Levenshtein distance.
The Levenshtein distance between two strings is defined as the minimum number of edits needed to transform one string into the other, with the allowable edit operations being insertion, deletion, or substitution of a single character. It is named after Vladimir Levenshtein, who considered this distance in 1965.
For example, the Levenshtein distance between "kitten" and "sitting" is 3, since the following three edits change one into the other, and there is no way to do it with fewer than three edits:
1.kitten → sitten (substitution of 's' for 'k')
2.sitten → sittin (substitution of 'i' for 'e')
3.sittin → sitting (insertion of 'g' at the end).
 

Input
There are several test cases. The first line contains a single number T shows that there are T cases. For each test case, there are 2 numbers in the first line: n (n <= 1500) m (m <= 1000) where n is the number of magic numbers and m is the number of queries.
In the next n lines, each line has a magic number. You can assume that each magic number is distinctive.
In the next m lines, each line has a query and a threshold. The length of each query is no more than 10 and the threshold is no more than 3.
 

Output
For each test case, the first line is "Case #id:", where id is the case number. Then output m lines. For each line, there is a number shows the answer of the corresponding query.
 

Sample Input
  
  
1 5 2 656 67 9313 1178 38 87 1 9509 1
 

Sample Output
  
  
Case #1: 1 0
 

题意:
给出一个字典,然后m个询问,每次给出一个字符串和一个k,让你找出字典中与该字符串最短编辑距离小于k的有多少个。(两字符串最短编辑距离:一个字符串经过 插入、删除、替换 最少需几步变为另一个字符串)

思路:
本体复杂度我没有降下来,906ms擦线过了 = =,就是每次枚举字典然后dp求最短编辑距离就够了。
dp初始化要记得dp[0][j]、dp[i][0]都是有意义的,不是INF,开始WA了。
s1、s2两字符串。
dp[i][j]   i-s1的位置  j-s2的位置  dp-最少操作几次能将前面的变为一样
if(s1[i]==s2[j]) dp[i][j]=min(dp[i-1][j-1],dp[i-1][j]+1,dp[i][j-1]+1);
else dp[i][j]=min(dp[i-1][j-1],dp[i][j-1],dp[i-1][j])+1;

代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1005
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

int n,m,k,ans,cnt,tot,flag;
char s[1505][15],len[1505],ts[15];
int dp[15][15];

void solve()
{
    int i,j,p,t,length=strlen(ts+1);
    ans=0;
    for(p=1; p<=n; p++)
    {
        if(abs(len[p]-length)>k) continue ;
        memset(dp,0x3f,sizeof(dp));
        for(i=0;i<=length;i++)
        {
            dp[0][i]=i;
        }
        for(j=0;j<=len[p];j++)
        {
            dp[j][0]=j;
        }
        for(i=1; i<=len[p]; i++)
        {
            for(j=1; j<=length; j++)
            {
                if(s[p][i]==ts[j]) dp[i][j]=min(dp[i-1][j-1],min(dp[i-1][j]+1,dp[i][j-1]+1));
                else
                {
                    dp[i][j]=min(dp[i][j-1],min(dp[i-1][j],dp[i-1][j-1]))+1;
                }
            }
        }
        if(dp[len[p]][length]<=k) ans++;
    }
}
int main()
{
    int i,j,t,test=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(i=1; i<=n; i++)
        {
            scanf("%s",s[i]+1);
            len[i]=strlen(s[i]+1);
        }
        printf("Case #%d:\n",++test);
        while(m--)
        {
            scanf("%s%d",ts+1,&k);
            solve();
            printf("%d\n",ans);
        }
    }
    return 0;
}
/*
1
5 2
656
67
9313
1178
38
87 1
9509 1
*/





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值