hdu 1009 FatMouse' Trade

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 31593    Accepted Submission(s): 10195
Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 
Sample Input
   
   
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
    
    
13.333 31.500
此题为简单的贪心  
不过要注意:
1.要认真审题 题目说f[i],j[i]为非负整数 即可以为0。
2.要考虑m用不完的情况。
我的代码:
#include<stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;
struct Tnode
{
	int f,j;
	double  fj;	
}node[10005];
bool cmp(Tnode& a,Tnode& b)
{
	return a.fj>b.fj;
}
int MAX=10000;
int main()
{
	int n,m,i,j,t;
	double s;
	while(scanf("%d%d",&m,&n)!=EOF&&!(m==-1&&n==-1))	
	{	
		s=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&node[i].f,&node[i].j);
			if(node[i].j!=0)  node[i].fj=node[i].f*1.0/node[i].j;
			else  node[i].fj=MAX;
		}
		sort(node+1,node+n+1,cmp);
		for(i=1;m>0&&i<=n;i++)
		{
			if(node[i].fj==MAX)  s+=node[i].f;
			else
			{
				if(m>=node[i].j)
				{
					m-=node[i].j;
					s+=node[i].fj*node[i].j;
				}
				else 
				{
					s+=node[i].fj*m;
					m=0;
				}
			}
		}
		printf("%.3lf\n",s);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值